Traverse Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just bought a 2009 Chevy Traverse. I absolutely love the car! But it’s been problems after problems. I’ve only had the car for maybe 3 months, and I’ve already put over $3000 into it. Which I don’t really have a problem with but I just done have the funds for it anymore. I just ran into a problem with my car not starting... you turn the key and all the lights come on, and you can hear the fuel pump. But when you try to start it, it does litterally nothing. We’ve replaced the starter, battery, ignition switch and looked at ALL the fuses. Nothing! At this point we’re cleaning all of the grounds hoping that works... but if not does anyone else have any suggestions? Or have had this problem? Thanks.
 

·
Registered
Joined
·
11,360 Posts
off the top of my head.
Go to the underhood fuse box.
find the relay named CRNK.
pull it out and check the prongs. then pull out the rear defroster relay (or another one with the same part # as the CRNK- there are 3 or 4). and swap them
Then see if it cranks and starts.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
off the top of my head.
Go to the underhood fuse box.
find the relay named CRNK.
pull it out and check the prongs. then pull out the rear defroster relay (or another one with the same part # as the CRNK- there are 3 or 4). and swap them
Then see if it cranks and starts.
thank you for the idea, I just tried it and still nothing.
 

·
Registered
Joined
·
3,068 Posts
Try checking the STRTR fuse. It's a 40 amp fuse to the right and slightly higher than the CRNK relay. Check it with a meter, don't just eye-ball it. (The Fan 2 fuse is also 40amp, so you could use that temporarily, if necessary. Once the car starts, swap them back.)

I've attached the starter circuit diagram. (Don't know why they call the relay "Starter Relay" instead of CRNK. They're usually pretty good about keeping the nomenclature the same.)

10105
 
1 - 4 of 4 Posts
Top