Traverse Forum banner

1 - 20 of 46 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
This will give us all an update to what mods or so you have done or going to do to your traverse.
Just a daily thing. :thumb:

I just finished bleeding my brake lines, added some new cross drilled rotors with new ceramic pads.
As I was in there, I just decided to paint the calipers as well. She stops even better now.
 

·
Registered
Joined
·
563 Posts
I traded my 09 Traverse for a 2014 Acadia this week. Best upgrade I could think of for my Traverse.
 

·
Registered
Joined
·
1,779 Posts
Travers had a bath wheel rotation and brake system clean and lube this weekend.

Power washer to the wheel wells and under side next weekend need to get the last bits of salt off.
 

·
Registered
Joined
·
11,234 Posts
checked the oil level.
 

·
Registered
Joined
·
30 Posts
2014 awd. We just got back from 5200 km road trip, car was 4 people weighted down to the max, got about 11L/100km with strong wind against us and way back 5 people 10.5L/100km. It was very nice to drive and less fatigue for driving and very solid car in all.
 

·
Registered
Joined
·
135 Posts
Complete vacuum clean every nook and cranny, since it was starting to smell with all the dog hair. Applied uv protection on all plastic, cleaned the leather and applied the conditioner, washed the outside, shampooed the carpet, the works - so yes, a good weekend to answer that question!
 

·
Registered
Joined
·
85 Posts
Ordered the speakers that I will install in the 3rd row. I ordered the speaker grilles yesterday.

I also will be ordering wheel locks.

Road trip next week so later this week I'll be taking her in for the first oil change/tire rotation and get her all cleaned up.
 

·
Registered
Joined
·
11,234 Posts
inspected water pump- and found it leaking... my brothers 2012 that is.
 

·
Super Moderator
Joined
·
2,040 Posts
How did you find out?

I'd like to look at mine, but I'm not sure where to look. My coolant level went down a few months ago, but hasn't moved since.
 

·
Registered
Joined
·
11,234 Posts
when I did his servicethe other day

http://www.traverseforum.com/index.php?topic=14890.0


- I topped off his reservoir. right to the full line.
the level was low. Figured hed never filled it.

Saturday we went to Legoland.
200 mile roundtrip.

Sunday morning- cold engine- I popped the hood to check take some pics of a 2012 engine bay...
and I looked at the reservoir---
It was low again..... OH OH.....

I turned on the car- turned wheel--- and got down there and looked....

yup-- traces of coolant leaking (none to the ground) but visible on the timing chain cover.....


HOW TO spot leak

http://www.traverseforum.com/index.php?topic=2430.0
 

·
Registered
Joined
·
55 Posts
Discussion Starter #13
rbarrios said:
when I did his servicethe other day

http://www.traverseforum.com/index.php?topic=14890.0


- I topped off his reservoir. right to the full line.
the level was low. Figured hed never filled it.

Saturday we went to Legoland.
200 mile roundtrip.

Sunday morning- cold engine- I popped the hood to check take some pics of a 2012 engine bay...
and I looked at the reservoir---
It was low again..... OH OH.....

I turned on the car- turned wheel--- and got down there and looked....

yup-- traces of coolant leaking (none to the ground) but visible on the timing chain cover.....


HOW TO spot leak

http://www.traverseforum.com/index.php?topic=2430.0


Great link. I think I might have the same problem too. I had to refill mine too.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #14
Added some 5000K morimoto's HID kit in her and upgraded the the amber side lights to LED's.
Also, did complete LED interior.
 

·
Registered
Joined
·
58 Posts
To kick off the 4th of July weekend, I decided to clean the backside of the wheels. Once I took them off I realized I HAD to clean the wheel wells and components as well!! Looks good. Almost as good as they day I took her home. Just have the drivers side left. :thumb:

Also performed weekly inspection while under there and everything looks great.

Hope everyone have a good 4th of July!!
 

·
Registered
Joined
·
488 Posts
Trans fluid again, been doing it every 25K at 50, 75 and now 100K miles. 5qts out, 5 qts in.
 

·
Registered
Joined
·
11,234 Posts
looks nice and clean!/


I cleaned my windows- from the outside.
Day 40 without a wash...... drought related.
 

·
Registered
Joined
·
32 Posts
I wouldnt say I did this today, more like an on going project for. The past three weeks.






Sent from AutoGuide.com Free App[/color]
 

·
Registered
Joined
·
58 Posts
Did you have something go out? Or were you just performing some serious overkill Spring Cleaning. Kinda nice seeing the inside like that. Lol. Great job.

But the question still remains..... Does everything still work? and Did you have any left over parts. Haha
Looks good
 
1 - 20 of 46 Posts
Top