Traverse Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2014 LTZ that has been having a problem with stabilitrak/traction control. Dealer say they cant find a problem. This Traverse has been to the dealer since it had 17000 miles with timing chain tensioners going bad, so they replace them after i took in for the seventh time. it has 73000 know with a stabilitrak traction control problems And the dealer say there is nothing wrong with it. I am just done! That’s the reason people purchase Japanese cars. So come September i am trading in for a rav4 or a highlander. I have purchase many chevys, 1.iroc, 2.454ss pick up, 3.gmc Yukon, 4. Suburban 5. 2500HD, 6. Camaro, 7. 1500 pick up 8.Corvette zo6, 9. Traverse. NO more chevy for me. DONE!!!
 

·
Registered
Joined
·
866 Posts
There are plenty of posts on this same message, if you search you will find plenty of options to try for resolving this annoying message.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I have a 2014 LTZ that has been having a problem with stabilitrak/traction control. Dealer say they cant find a problem. This Traverse has been to the dealer since it had 17000 miles with timing chain tensioners going bad, so they replace them after i took in for the seventh time. it has 73000 know with a stabilitrak traction control problems And the dealer say there is nothing wrong with it. I am just done! That’s the reason people purchase Japanese cars. So come September i am trading in for a rav4 or a highlander. I have purchase many chevys, 1.iroc, 2.454ss pick up, 3.gmc Yukon, 4. Suburban 5. 2500HD, 6. Camaro, 7. 1500 pick up 8.Corvette zo6, 9. Traverse. NO more chevy for me. DONE!!!
Update:::::: Got to my chevy dealer 3 more time after the first post. No problem fund, What! I started by 1. replace battery, same problem. 2. Removed battery back out and clean ground in battery box and under air filter box till you see good metal showing. Installed battery back on. Road Test for 150 miles 3.5 hours. no more problems as of now. Original problem was stabilitrak/traction control on dash with no check engine light or no ABS light. Good luck to all the Chevy Traverse people out there. ( going to sell it anyway).
 

·
Registered
Joined
·
148 Posts
Update:::::: Got to my chevy dealer 3 more time after the first post. No problem fund, What! I started by 1. replace battery, same problem. 2. Removed battery back out and clean ground in battery box and under air filter box till you see good metal showing. Installed battery back on. Road Test for 150 miles 3.5 hours. no more problems as of now. Original problem was stabilitrak/traction control on dash with no check engine light or no ABS light. Good luck to all the Chevy Traverse people out there. ( going to sell it anyway).
Thanks for the update.
 

·
Registered
Joined
·
2 Posts
Update:::::: Got to my chevy dealer 3 more time after the first post. No problem fund, What! I started by 1. replace battery, same problem. 2. Removed battery back out and clean ground in battery box and under air filter box till you see good metal showing. Installed battery back on. Road Test for 150 miles 3.5 hours. no more problems as of now. Original problem was stabilitrak/traction control on dash with no check engine light or no ABS light. Good luck to all the Chevy Traverse people out there. ( going to sell it anyway).
No CEL may indicate wheel sensor issue.


My issue did throw CEL and resolved by cleaning throttle body, MAP sensor and a few motor oil flushes.
 

·
Registered
Joined
·
13 Posts
There are plenty of posts on this same message, if you search you will find plenty of options to try for resolving this annoying message.
The one thing I don't see here is checking wheel speed sensor systems. My 2012 had check engine light, traction control / stabilitrak, engine power reduced and other bogus error codes. Eventually found wheel speed sensor and hub wheel sensor were bad. The code for that didn't show up directly. I monitored wheel speed on all four while driving and the bad one showed an on/off lower MPH than the other three. Removing the hub/wheel bearing found the magnetic strip on it had a gap in the magnetic ring.
 

·
Registered
Joined
·
866 Posts
I have a Bluedriver which I am not sure checks the wheel speed sensors. My Innova scanner will do a full ABS sensor scan, it is handy to have.
 

·
Registered
Joined
·
6 Posts
Stabiltrak issues --- this is one of the biggest complaints I have heard from other Traverse owners. In fact, I have heard from two Traverse owners who are A-OK with their cars with the exception of Stabiltrak issues.
I have 10 years of experience with my 2011 Traverse and what I have learned is that Stabiltrak, Cruise Control, and Tire Pressure Monitor are all connected. When you have problems with one, you will eventually have problems with the others. I have also learned that problems with these three things are sometimes very simple to correct. Cleaning the throttle body almost always corrects the Stabiltrak issue. Cleaning the TPM can sometimes correct it. It has a battery but it is a sealed unit. If Stabiltrak warning comes on and then Cruise Control fails, you can sometimes simply reboot it ---- park, cut the engine, wait 30 seconds, restart the engine and, viola, you're good to go.
If anyone from Chevy corporate ever reads this forum, look at how many posts there are about Stabiltrak. Correct this silly, silly issue on an otherwise very reliable and very economical vehicle!
 

·
Registered
Joined
·
3,311 Posts
I don't think we've seen a GM rep on here in about 3 years. And even then, it was just CSR's who claimed they'd help get you set up with a dealer (because apparently many of don't know we have dealers?).
 

·
Registered
2020 High Country
Joined
·
562 Posts
Stabiltak and Traction warning will always appear when any powertrain or brake code sets.
GM vehicles have been doing that since the '00's.
 
1 - 10 of 10 Posts
Top