Traverse Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Sometime when accelerating at low speed the transmission seems to “shake” like it’s trying to decide which gear it wants to be in.
my BMW 328 was doing that and the mechanic said the clutch’s wear and he added some special fluid to the trans and the problem went away.
Does the Chevy have the same condition? My Traverse has 45K miles.
Any help?
 

·
Registered
Joined
·
11,902 Posts
Transmission shudder.
Its been reported on the 2nd gen models.
Something about moisture and the trans fluid. Owners or dealers drain the trans fluid and refill with one of Mobils trans fluid, which is good at not absorbing moisture.
Also, others add a product to trans fluid that helps with shudder.
 

·
Registered
2020 High Country
Joined
·
1,048 Posts
Still under the powertrain warranty? If so, take it in.
 

·
Registered
Joined
·
16 Posts
Take it in and have them reset the TCM. My 2020 did that and that was the issue. If you search the forum you will find others who had the same problem. They also changed the transmission fluid I believe.
 

·
Registered
Joined
·
19 Posts
Our 2018 had the same transmission issues... the solution was to drain the trans and replace the factory fluid with Valvoline low viscosity synthetic ATF. That single step did absolute wonders. If your car is second generation, you need to be aware the Valvoline fluid meets the GM Dexron 6 specifications for that finicky nine speed transmission. The Mobil 1 fluid does NOT (as far as I'm aware). Not an issue if its a 2017 or older model. There are threads about the trans fluid fix on the forum.
 
1 - 5 of 5 Posts
Top