Traverse Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
331 Posts
Discussion Starter · #1 ·
Guys,

I've been chasing some gremlins with my 12' LTZ as it's been having issues with a delayed shift from Reverse to Drive and from Park to Drive as well as sometimes slow/strange shifting on the highway as well as some slight shuttering between 1-2. I finally broke down and bought a scanner (OBDLink MX2 - Amazon.com: OBDLink MX+ OBD2 Bluetooth Scanner for iPhone, Android, and Windows: Automotive) and even with no dash lights and warnings I pulled 2 transmission codes P0989 and P0877 (Transmission Fluid Pressure Sensor/Switch "E" Circuit Low and Transmission Fluid Pressure Sensor/Switch "D" Circuit Low). After a little research I found the likely culprit to be our wonderful laminate discs on the pressure sensors of the TCM in the transmission as it seems to be a common failure point on the 6T75 transmission that we have. Here's a link to how to do the repair and I won't reinvent the wheel:


Also below are some pics of my TCM as you can see the laminate discs are clearly broken and here's a link to the kit I bought on Amazon (https://www.amazon.com/gp/product/B08RBH7YDH/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1) and if you are doing this repair, make sure to seat the discs properly and also the tool for the seal installation is a little finnicky and you need to make sure the seal is pushed in properly to the tool so it will push into the TCM straight. Once the rubber seal is in, check it with a small flat head screwdriver to ensure it's seated fully and plenty of light. The transmission is still relearning and I'll see how it responds after this week as we have a long drive a head to West Texas and it will give the transmission plenty of time to relearn.

10502
10503
 
  • Like
Reactions: cintocrunch

·
Registered
Joined
·
11,570 Posts
My most noticeavle symptom was reverse or Park to Drive. Up to 3 seconds to feel the engagement of Drive.
But once I changed out the discs, it took about 80 miles and a couple of cold engine starts for the trans to learn- and reflect the immediate engagement of D. literallt a fraction of a second.
 
  • Like
Reactions: dave00

·
Registered
Joined
·
331 Posts
Discussion Starter · #3 ·
My most noticeavle symptom was reverse or Park to Drive. Up to 3 seconds to feel the engagement of Drive.
But once I changed out the discs, it took about 80 miles and a couple of cold engine starts for the trans to learn- and reflect the immediate engagement of D. literallt a fraction of a second.
Excellent, that's the main symptom I was getting as well. Looking forward to the relearned feel!!!
 
1 - 3 of 3 Posts
Top