Traverse Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
994 Posts
Discussion Starter #1
All morning the temp. reading on the DIC displays 11C. True temp is around 21C. Didnt I see somewhere posted a similar problem?

UPDATE:

Within 100 feet of driving into the dealership the DIC temp very quickly went from 11 to 13 to 15 to 17 and settled on 18C. Now the true exterior temp is 21C (and my other car is showing that correctly) but I wasnt going to take in the Traverse at this point to deal with temp inaccuracy.
 

·
Registered
Joined
·
11,235 Posts
Ive seen this problem on the trailblazers...
On the trailblazers.. theres 2 possible fixes...
1st one most try is theres a combination of buttons that they press simultaneously- that resets the sensor- and sometimes it works again...
if that fails... most replace the sensor. to not detect heat from engine... it is placed in the grille area-- in front of the radiators.. where it picks up the ambient air temp. Most go to dealer and buy the part and snap it in.. it something like $10.

I wonder if the traverse has a special key press combination to force the reset.....
 

·
Registered
Joined
·
994 Posts
Discussion Starter #3
I did drop off our Traverse this afternoon. I am hoping they will replace the sensor and connecting wire(s). Although I did see on the Acadia forum a bulletin # for a similar problem for 07 and 08 Acadias and Outlooks I would have thought this would be rectified for all 09s. I dont know. ???
 

·
Registered
Joined
·
73 Posts
Not too uncommon. When you drive the vehicle at more than 18 miles per hour for x amount of time the sensor resets. This is not un heard of. My Outlook did it and my Acadia does from time to time.

Do you have the auto a/c system? if you do, holding down the "*" button and the recycle button at the same time will also re-set the temp.
 

·
Registered
Joined
·
994 Posts
Discussion Starter #5
khansen30 said:
Not too uncommon. When you drive the vehicle at more than 18 miles per hour for x amount of time the sensor resets. This is not un heard of.
It was heard of enough for the 07 and 08 Lambdas for GM to issue a bulletin. I was hoping 09 would benefit from this experience.

khansen30 said:
Do you have the auto a/c system? if you do, holding down the "*" button and the recycle button at the same time will also re-set the temp.
I have the 1LT so no auto climate. But there must be a way to reset temp on non auto climate cars.
 

·
Registered
Joined
·
994 Posts
Discussion Starter #6
The dealership replaced the temp sensor this morning...under warranty.
 
1 - 6 of 6 Posts
Top