Traverse Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Has anyone tried Range Technology start stop disabler on 2021 yet? I would like to find out if it works or any other pertinent info. Thanks
 

·
Registered
2020 High Country
Joined
·
562 Posts
I have a Range unit in my '20 that was listed at the time for a '19 for a year / 10k miles now no issues.
 
  • Like
Reactions: snobrdrdan

·
Registered
2020 Traverse LT
Joined
·
42 Posts
I have the Range in my 2020. This company is a part of the Holley group, and they were big in performance years ago. I figure they would not sell crap. Have had mine 6-7 months now. Only problem is during that time, I've had the engine shut down once or twice on maybe 4-5 occasions. I mean that the stop/start function in the car worked. I am happy with it, and if we have an occasional stop/start that is ok with me. At least it is not the original equip function.
Buy the Range, install it, and you will be happy.
 

·
Registered
2020 High Country
Joined
·
562 Posts
I have the Range in my 2020. This company is a part of the Holley group, and they were big in performance years ago. I figure they would not sell crap. Have had mine 6-7 months now. Only problem is during that time, I've had the engine shut down once or twice on maybe 4-5 occasions. I mean that the stop/start function in the car worked. I am happy with it, and if we have an occasional stop/start that is ok with me. At least it is not the original equip function.
Buy the Range, install it, and you will be happy.
I get an occasional ''misfire'' with my Range AFM eliminator in my Tahoe. Maybe once every couple of months that I can feel it going into V4 mode. But a restart after an event and it's fine again for month's. 90k miles on that unit, looks and installs the same as the auto stop in the Traverse. Main thing is I still have OEM lifters and cam at 124k miles.
No issue in the Traverse yet.
 

·
Registered
Joined
·
7 Posts
In my 2019 with AWD, If you shift into L before taking off, it will not turn off when stopping at traffic lights. You will need to manually shift up through the gears with the + and - on the shift knob the first time. After that, it it automatically shifts normally until you shut off the vehicle. Thanks to GreenTraverse for this tip.

John
KD4FTA
 
1 - 5 of 5 Posts
Top