Traverse Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
994 Posts
Discussion Starter #1
With the replacement of the rack several weeks ago the 'rubbing and wheezing' emanating from the steering wheel/column was rectified. However there still remains these annoying and unexpected 'pops and squeaks'. I think they come from the rear end of the vehicle (struts/bushing/'suspension'/... ???) and can happen with and w/o turning; but I cant always reproduce the problem which of course makes it problematic bringing it to the dealer. But I do find it bothersome as it makes the car sound much older and much more used than would be indicated by its mileage or MY.

Anyone else experience or read about something similar in these Lambda forums for an 09?
 

·
Registered
Joined
·
121 Posts
I've got the annoying 'pops and squeaks' from the rear also.... So far I've adjusted the striker for the rear hatch(to make the hatch close tighter), removed the inner panel & secured any wires/connectors, added some sound proof to tighten the fit of the rear inner panel and lubed the hinges/seals. It still happens.... I have sat in the rear while my wife drove and found that the rear hatch moves a little when going over bumps. it's almost like the hinges are too small to support the weight of the door.. :(
 

·
Registered
Joined
·
994 Posts
Discussion Starter #4
Zubius said:
I've got the annoying 'pops and squeaks' from the rear also.... So far I've adjusted the striker for the rear hatch(to make the hatch close tighter), removed the inner panel & secured any wires/connectors,
Thanks for the reply Zub but I am sure my metal popping sound and squeaks are from further below, from that nebulous area known as the "suspension". And probably hard to pin point specifically re parts.
 

·
Registered
Joined
·
113 Posts
lmao...if you are having "pops and squeaks" from your rear-end, isn't it time to see your doctor??? lmao...sorry...couldn't resist... ;D

Medman :beer:
 

·
Registered
Joined
·
5 Posts
Having the same issue but mine is coming towards the front end. Popping or squeaking noise makes vehicle sound like it is 10 yrs old. Could it be the bushings?
 

·
Registered
Joined
·
1,779 Posts
Have you had the rear half shafts checked. It almost sounds like they are bad.

Are only people with AWD having the popping or is anyone with just front wheel drive.

I would also check and see if the spring insulators are ok.
 

·
Registered
Joined
·
417 Posts
My Traverse has been the noisiest vehicle I've owned in a long time. It's not bad, but it does have a few annoyances.

1. The worst one is I believe in the seat belt on the seat behind the driver. It's got a squeak that is almost 100% of the time. A little metallic squeak that continues over almost any road condition.
2. There seems to be a loose wire under the dash that rattles on large bumps up against the top dash plastic from underneath.
3. This one just started. My drivers seat has a very loud creak when I stop and start. I can wiggle hard enough to make it creak too. I've got the 8 way power seat and usually have it set all the way to the top of the adjustment for height. If I move the seat all the way to the bottom (WOW it's got a lot of travel!) I can get the noise to stop. I've tried to apply lithium grease as an attempt to make it stop, but I've not hit the right spot yet.

A little bit of radio pretty much removes all annoyances, so I'm not too upset. But I would like to get these fixed. The first 2 seem fixable, but I'm worried about the 3rd. I don't see GM replacing the seat under warranty, I just might have to try that though. None of these are "failures", so we'll just have to see what my dealer can do.
 

·
Registered
Joined
·
994 Posts
Discussion Starter #11
copperbeech said:
I was in error :-[. The noise according to the mechanic was actually from the front end. See here for more detail (reply #80 and onward):

http://www.traverseforum.com/index.php?topic=687.msg6581;topicseen#new
I got the Traverse back noon this past Saturday (new front strut mounts and lots of re-torquing) and was told that the 'pops and squeaks' are no more. I have driven it subsequent to this and can say that the problem is still there...very frustrating. They are willing to look at it again but I am not sure what else they can try.
 
1 - 11 of 11 Posts
Top