Traverse Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
2009 Chevy Traverse LT
Bought it from a friend and then realized it has some issues.
1) The interior lights wont turn on when any door is opened. I have checked the dimmer switch and turned the instrument panel dimmer and they turn on that way. But nothing when door is opened.
2) Front speakers work intermittently and back door speakers dont work at all. Only tweeters on front support beams work. RADIO DOESN'T TURN OFF WHEN DOOR IS OPENED Either.
Microphone also seems to be inactive for me.setting up bluetooth.
3) passenger seat belt light continues to flash even when passenger is in seat and buckled.

Can anyone help me with any of this? Fuses maybe? Ugh. So disgusted
I'd gladly pay someone to help me.figure this out
Please and thanks
Jon
9242
 

·
Registered
Joined
·
77 Posts
Doesn't sound like a great friend but buyer beware I guess. There's ton of information on here about your issues but no one answer will solve it for all. I suggest searching and trial and error.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
720 Posts
Usually a bad switch inside the lock mechanism will prevent the radio from turning off, it should go off after 10 minutes though. The stock speakers on there were crap, get yourself some decent aftermarket speakers.
#3 could be a bad switch in the seat belt latch.
Don't know about the microphone.
I can post a wiring diagram tomorrow for the door circuit. Is there a override feature for the lights by the dimmer? A little rocker type, above the dimmer. Do you have a remote keyless entry fob and do the lights work when you unlock?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
I do have the fob and the lights only turn on when use the dimmer switch. The exterior lights turn on not the interior.
 

·
Registered
Joined
·
720 Posts
How about when you pull the key out, do they go on then? That option is changeable through the DIC custom settings. Do you have the owners manual? If not they are available online. Read up on customizing.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
I was able to get the option working for approach lights interior to work still no lights when drivers door opens and radio still doesn't shut off either. I'm continuing to research. The front speakers worked today. Back ones have yet to work. I thank you for your help so far.
 

·
Registered
Joined
·
2,760 Posts
Might be a stretch, but check door connector for water; common issue affecting speakers and windows. Pull it apart and dry it out. Use some dielectric grease to keep water out.
 

·
Registered
Joined
·
77 Posts
I've done that on mines and stuffed it with electric grease and I still have the same problem. I believe it has helped and will long term but I'm leaning towards cheap speakers with broken connection at the cone or a bad radio as the culprit.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
720 Posts
Unfortunately the switch for the door open indication is in the latch assembly so you would need to replace the whole thing at $150, if that is the problem. You may be able to take it apart and repair the switch malfunction but I haven't heard of anybody tackling this. Yes you may have a bad connection in the door connector assembly. It may be the latch assembly.
Another indication you would get from the switch operating, if you open the door with the ignition on and transmission in Drive, you would get the door open message on the DIC, if not then the feedback to the BCM isn't working.
I had a 2008 Outlook with the radio not shutting off with the passenger door opening, I was able to live with that, now my 15 Enclave has the same issue, passenger door, I greased it up, it sometimes works, sometimes not.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #14
I'm going to look up the latch Assembly and order one. I'm taking the door apart anyway to put new front speakers in. Is it a fairly simple procedure to put the new latch in??
 

·
Registered
Joined
·
720 Posts
I don't think it is a big deal, I believe the most difficult part would be the cable which attaches to the manual unlock button.
 

·
Registered
Joined
·
77 Posts
I don't think it is a big deal, I believe the most difficult part would be the cable which attaches to the manual unlock button.
Take your time and be extra careful with the rod clip as they can break easily. Take pictures of everything before or video. Most latches I've done are not difficult to get out but do require attention and patience as may become frustrated getting it out through sometimes tight spaces. Peel away the plastic cover slowly sontou can reuse it also and don't cut it or rip it. Good luck.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
14 Posts
2009 Chevy Traverse LT
Bought it from a friend and then realized it has some issues.
1) The interior lights wont turn on when any door is opened. I have checked the dimmer switch and turned the instrument panel dimmer and they turn on that way. But nothing when door is opened.
2) Front speakers work intermittently and back door speakers dont work at all. Only tweeters on front support beams work. RADIO DOESN'T TURN OFF WHEN DOOR IS OPENED Either.
Microphone also seems to be inactive for me.setting up bluetooth.
3) passenger seat belt light continues to flash even when passenger is in seat and buckled.

Can anyone help me with any of this? Fuses maybe? Ugh. So disgusted
I'd gladly pay someone to help me.figure this out
Please and thanks
Jon View attachment 9242
earlier traverse's was common to have water leaks from sunroof, the water will travel down the front posts where the tweeter speakers are. the water gets into the door connector that you see when the doors are open.
I have a 2009 too, I replaced the microphone in the panel with the lights over your head and fixed connecting with onstar computer. my car doesn't have bluetooth for connecting to phone. I use a simple brand device to use phone and the new microphone solved connecting to onstar and setting up phone directory.
water that gets into doors from windows will damage the speakers, very common, I bought speakers and install parts from crutchfield, they are very helpful. I also installed 4 inch speakers in the third row seating and paired them with the read door speakers harness but you may already have them.
have you checked for a loose connector on back of radio? I had the locking tab break off, I think I used a paper shim to p the connector in. been fine for years.
there is also a connector in the harness that runs between the radio and the door connector that may be loose.
the chimes ring in the driver side front speaker and is not controlled by volume. but if the speaker or connectors fail you won't hear bell tone.
harness issues are common in the 2009.
hope this helps
john
 

·
Registered
Joined
·
720 Posts
JVOYE, How are you making out? We just had a member on the Acadia Forum with no overhead lights as well. It turned out to be a short circuit to ground on the Bk/Grey wire. It must have happened when the recall on the hatch struts was done. The culprit was by the hatch where the Airbag on the drivers side. You can check out his post on Acadia.
First thing to check is all your door switches.
With ignition on, doesn't need to be running, and put it in drive. One by One open the doors to see if the BCM gets the input, the Driver Information Center will say which door is open.
Then you would need to see if you have power on the GR/BK wire, or if it has a short. Do you have a multimeter, or know someone who does?
 
1 - 18 of 18 Posts
Top