Traverse Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Hey guys,

Just got my 2010 back from body work a couple weeks ago (not my fault, other insurance paid). No component damage. Anyway the idle is a bit rough now. I thought at first that it was just old gas but new gas didn't affect it.

Now before I took it in, it one time started and ran way worse and I had the codes for random misfire and Fuel System Request MIL Illumination. However this problem went away a few minutes after it started.

Do you think I have a bad fuel rail pressure sensor and the ECU is just compensating for the bad data? Starts, runs, drives, and sounds pretty good but the RPM gauge won't stay still, probably ±50 rpm moving around at idle. When driving it is steady.
 

· Registered
Joined
·
67 Posts
Discussion Starter · #3 ·
Should be clean but I will check again, and air filter. Plugs IDK... it's possible they are too old. But if a plug was going bad wouldn't that throw a misfire code for one cylinder?
 

· Super Moderator
Joined
·
1,385 Posts
Worn plugs can misfire when cold and run OK once warmed up.
 

· Registered
Joined
·
6 Posts
Should be clean but I will check again, and air filter. Plugs IDK... it's possible they are too old. But if a plug was going bad wouldn't that throw a misfire code for one cylinder?
I can literally set at idle and watch my fuel economy drop a tenth every few seconds. I’ve replaced coil packs, spark plugs, maf sensor and checked all vacuum lines. Within last month,yesterday flashing engine light. Code was misfire, cylinder 4. WTH. Btw, bought TRQ PLUGS AND COIL PACKS FROM AMAZON. Even though they say plugs are preset, one plug the gap was closed. I checked all of them only one in six was correct. Still poor mileage and a miss sometimes at idle. Frustrated 2015 Traverse LT
 

· Super Moderator
Joined
·
1,385 Posts
I can literally set at idle and watch my fuel economy drop a tenth every few seconds. I’ve replaced coil packs, spark plugs, maf sensor and checked all vacuum lines. Within last month,yesterday flashing engine light. Code was misfire, cylinder 4. WTH. Btw, bought TRQ PLUGS AND COIL PACKS FROM AMAZON. Even though they say plugs are preset, one plug the gap was closed. I checked all of them only one in six was correct. Still poor mileage and a miss sometimes at idle. Frustrated 2015 Traverse LT
When you are sitting with engine idling, in gear or in neutral, you are getting ZERO miles per gallon. Thus you can watch the fuel economy drop right before your eyes when travelling at zero miles per hour and getting zero MPG.
TRQ parts = garbage. AC plugs and GM ignition parts only.
 
  • Helpful
Reactions: RandyMan
1 - 7 of 7 Posts
Top