Traverse Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey guys, I could really use some help here. I have a 2011 Chevy Traverse with 89000 miles. Back in June I got the code of PO496. We replaced the purge valve that is located on top of the engine just under the cover. Less than a month later I get a code of PO497. This code I believe from what I can find is a EVAP code for low purge flow. I have replaced the gas cap, the vapor canister vent valve/solenoid and the vapor canister. (these are located on top of the gas tank). I figured if I had to drop the tank to replace the solenoid I might as well get the canister too. Hoping to avoid any further issues. This did not work. I replaced the solenoid and canister on 08/19/21 and the codes removed and today when I started the car for work the check engine light is back on and my OBII scanner gives me the code of PO497 again. Any suggestions on what else could be wrong and where to start to fix this. Thanks for any help anyone can provide.
 

·
Registered
Joined
·
11,611 Posts
Smoke test?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
No. I haven't done that. Guess I will have to look into how to do that and get that done. Thank you.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
I replaced and got a bad part so replaced again with NP. Heres what Tech calls for, hope this helps
I am guessing the smoke test rbarrios recommended with help determine if I got any bad parts and help weed out anything else that might be and issue. Thank you for the tech sheets.
 
1 - 7 of 7 Posts
Top