Traverse Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
The power lift gate opens fine like it should but it makes load pop at the top of opening and immediately start to automatically close itself. I can push it up manually as it is rising after the key fob, interior lift gate button or the button on the lift gate itself is activated and it will not close automatically but then it will not stay up. I have to use a long stick to hold it open while loading and unloading the back. Help!!!! My wife is complaining of looking like a getto idiot at the grocery store. Our warranty has expired so I thought I might try to fix myself. What holds the gate open? The two struts on the side or the mechanical lifting bar? Thanks for any info.
 

·
Registered
Joined
·
223 Posts
The struts on the sides. I just took mine off one at a time to oil them up. There is a lot of weight that they are holding up. Every couple of months I do that to everything back there during the Winter.
 

·
Registered
Joined
·
118 Posts
The struts are what actually hold the lift gate up so I would replace them first, there not super expensive and it's fairly easy to do. Now as far as the noise made at the top this is most likely because the motor is pushing the lift gate past the height limiter, if it is still doing it after replacing the shocks your lift gate might need to be recalibrated which unfortunately can only be done at a dealership.
 

·
Registered
Joined
·
865 Posts
What it really sounds like is that the motor/gear assembly may be shot. Ours goes up and down at least 4 times a day and was making a loud pop (when the gate gets to its highest point) on the strut that is connected to the motor, but I lubed everything up and the noise is all but gone. There is still some slop in the gear assembly on the motor and it's only a matter of time before I have to replace it. That assembly is $400 :eek: at the dealer and doesn't look too difficult to install once the interior panel is off.

Best of luck getting yours sorted out.
 

·
Registered
Joined
·
7 Posts
The power lift gate opens fine like it should but it makes load pop at the top of opening and immediately start to automatically close itself. I can push it up manually as it is rising after the key fob, interior lift gate button or the button on the lift gate itself is activated and it will not close automatically but then it will not stay up. I have to use a long stick to hold it open while loading and unloading the back. Help!!!! My wife is complaining of looking like a getto idiot at the grocery store. Our warranty has expired so I thought I might try to fix myself. What holds the gate open? The two struts on the side or the mechanical lifting bar? Thanks for any info.
Have the same problem (2012 LTZ) 130k. Just started. Using inside switch, fob or at the handle. Lift releases and opens till just about full then auto closes and can not be stopped. If I hold it on the way down, it disengages and I can hold it open. It will not hold itself up. Lowering it manually it locks and then original problem repeats. Checked and tested the fuse under the hood. Ok. One other fuse under dash by passenger seat did not check but based on what is happening I think it is still good. The only thing I can not think of is the struts have weakened to point they will not support weight of lift gate and it immediately closes as a safety. Replacing the struts may be an option as they can be purchased on line fairly cheap.
Would appreciate any advise from someone who knows
Thank you
Joe from Monson MA
 

·
Registered
Joined
·
169 Posts
I would try to replace the struts first. It is a heavy door, the system wants to protect the motor so if the struts not helping to ease the weight then it just quit. It is a nine years old car, the struts wont last forever.
 

·
Registered
Joined
·
7 Posts
I would try to replace the struts first. It is a heavy door, the system wants to protect the motor so if the struts not helping to ease the weight then it just quit. It is a nine years old car, the struts wont last forever.
Thanks for quick reply. I agree this seems to be best and least costly approach. Can you suggest how to get hatch open to stay. It wants to close immediately. Tried removing 30 amp fuse and latch would not release. Not sure how to do to screwdriver thru back panel from in inside with no success
 

·
Registered
Joined
·
169 Posts
Press the liftgate power button under your radio that should disable the power mode of the liftgate. Manually open your liftgate using the touchpad on the outside liftgate handle. Prop up the liftgate with a pole or get a second pair of hands when you replace the struts. Two minutes work to swap them out.

Do put the fuses that you removed back to the fuse block. You need the power to engage the latch and use the touchpad to open the liftgate.

Good luck.
 

·
Registered
Joined
·
7 Posts
Press the liftgate power button under your radio that should disable the power mode of the liftgate. Manually open your liftgate using the touchpad on the outside liftgate handle. Prop up the liftgate with a pole or get a second pair of hands when you replace the struts. Two minutes work to swap them out.

Do put the fuses that you removed back to the fuse block. You need the power to engage the latch and use the touchpad to open the liftgate.

Good luck.
Will try that tomorrow. Thanks
 

·
Registered
Joined
·
7 Posts
Will try that tomorrow. Thanks
Ordered struts on Amazon. Arrived today. Installed in less than 5 minutes. Problem solved. Thanks fir your helpful advice. Should use two people. One to hold the other to install. My second was a sturdy broom handle. That hatch is heavy
 

·
Registered
Joined
·
7 Posts
Ordered struts on Amazon. Arrived today. Installed in less than 5 minutes. Problem solved. Thanks fir your helpful advice. Should use two people. One to hold the other to install. My second was a sturdy broom handle. That hatch is heavy
By the way, struts cost $25.00 for the pair!
 

·
Registered
Joined
·
169 Posts
By the way, struts cost $25.00 for the pair!
Thanks for the update. What brand did you get? I am trying to avoid products from certain country. Ordered an ACDelco turn signal & headlight dimmer switch from Amazon for my other vehicle, unfortunately it was made in ""! Don't know how long it will last, but the vehicle is 12 years old, so I just went ahead and install it.
 

·
Registered
Joined
·
7 Posts
Ordered struts on Amazon. Arrived today. Installed in less than 5 minutes. Problem solved. Thanks fir your helpful advice. Should use two people. One to hold the other to install. My second was a sturdy broom handle. That hatch is heavy
Thanks for the update. What brand did you get? I am trying to avoid products from certain country. Ordered an ACDelco turn signal & headlight dimmer switch from Amazon for my other vehicle, unfortunately it was made in ""! Don't know how long it will last, but the vehicle is 12 years old, so I just went ahead and install it.
The name of the company is. Schnecke. But it is made in @&$?/ Sorry . I have bought other parts for my John Deere Lawn Tractor from that same company (Starter) and it is still working.
 
1 - 16 of 16 Posts
Top