Traverse Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
272 Posts
Discussion Starter #1
I just checked Autozone online for the price of the PF48 filter. They show a PF48S filter is required for the Traverse. What is the S for?
 

·
Registered
Joined
·
994 Posts
But on page 6-14 of the 09 Traverse manual it lists PF48 as the AC Delco Part #.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #3
I purchased the PF48 filter at Autozone. It came up on the receipt as a PF48s but the box clearly shows PF48. Everything appeared to be the same visually as the factory filter except for the red gasket and label. The gasket had red flakes coming off of it so I assume the red color is a lubricant on the gasket itself since the factory probably doesn't put oil on it before installing. The factory filter label shows to replace it with a PF48. One other note, the factory filter has a part # of 8901 7624. The AC Delco one is marked with 8901 7524. This probably notes the lubricated gasket. The AZ filter wrench everyone recommended worked great! It mangled the filter a little but it came off. The only other tough part was draining after a 30 min. drive. Blackstone wants the sample taken after a 20 min highway run. I will post the results when I get them. I just drained the factory fill at 2377 mi and am anxious to see what the sample shows. Sorry for being long winded!
 

·
Registered
Joined
·
994 Posts
kawazar said:
I will post the results when I get them. I just drained the factory fill at 2377 mi and am anxious to see what the sample shows. Sorry for being long winded!
I will be interested to see the #s.

Btw, did you indicate in your post what you refilled with?
 
1 - 5 of 5 Posts
Top