Traverse Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
994 Posts
Discussion Starter #1
Heck I feel better now just saying it :-[.

Since late September I have been adding, at every other gas fill-up, one of these two products (approximately 3 oz each time):


I know many of you will say it isn't necessary if one uses tier 1 fuel but I still do it :-[.

Okay some of you got to be closet fuel additive users? Come on, confession is good for the soul ;D. What do you use?
 

·
Registered
Joined
·
1,071 Posts
Okay some of you got to be closet fuel additive users? Come on, confession is good for the soul Grin. What do you use?

Only Tier 1 Gasoline!
 

·
Registered
Joined
·
718 Posts
I haven't used anything in the Traverse as of yet, but in my 04 Silverado I put a bottle of Amsoil P.I. in about every 5-6K. Started doing that when it hit about 90K miles. It's at 114K now.
 

·
Registered
Joined
·
34 Posts
Count me in - I add a bottle of the Redline in the Fall in each of my rides.

Why? Because.

.
 

·
Registered
Joined
·
860 Posts
Tier 1 gas. A can of BG44K once a year, usually in the early fall. Anything else is overkill for me.
 

·
Super Moderator
Joined
·
2,043 Posts
Oh, I don't even use tier 1 gas.....just whatever stuff Sam's Club dispenses. Can't complain, I get great fuel mileage.
 

·
Registered
Joined
·
11,417 Posts
I use Chevron Techron Fuel Injector Cleaner/Fuel System Cleaner-

In My 2003 Trailblazer I used 1 bottle about 1 tankful before every oil change. On that vehicle it was about every 10-11,500 miles- Based on the OLM.
The Trailblazer, Envoy, Bravada, Ascender forum- there was MANY people who complained of erratic fuel readings on their fuel gauge- and eventually non functional gauge- which meant a new fuel pump--- some were able to get the float only--- but most shops did the pump/float as a whole unit. Many times the erratic performance was caused by sulfur build up on the fuel pump floats variable resistor
Well after 133,000 no erratic readings on mine. I changed out my factory pump at 133K (preventative maintenance- as my pump was not showing signs of failure)but I changed it since I was about to travel halfway into Mexico....

Well now at 157,000 - no injector or fuel level issues.

Ill continue to do Techron every 10,000 or about every 2 oil changes on my Traverse--- more to keep away the sulfur buildup
 

·
Registered
Joined
·
994 Posts
Discussion Starter #8
It seems I am one of the few to use a gas treatment at the 'maintenance' level i.e. a few oz in every other tank of gas?
 
A

·
Guest
Joined
·
0 Posts
rbarrios said:
The Trailblazer, Envoy, Bravada, Ascender forum- there was MANY people who complained of erratic fuel readings on their fuel gauge- and eventually non functional gauge- which meant a new fuel pump--- some were able to get the float only--- but most shops did the pump/float as a whole unit. Many times the erratic performance was caused by sulfur build up on the fuel pump floats variable resistor
I had the same issue on my 05 Envoy before I traded it for the Acadia
 

·
Registered
Joined
·
11,417 Posts
copperbeech said:
It seems I am one of the few to use a gas treatment at the 'maintenance' level i.e. a few oz in every other tank of gas?
I thought I read somewhere that using the cleaners TOO often- can be bad- as it can damage rubber seals etc...
This is probably in concentrated form.... so it must not apply to small doses.
 

·
Registered
Joined
·
11,417 Posts
AA/78U said:
I had the same issue on my 05 Envoy before I traded it for the Acadia
Yeah- this was pretty common issue to see on the forums.
It was an expensive fix. I changed my own pump- the cost was about $320 for the pump itself (and float).-- once again, mine never acted up- but I was going to be driving down to Guadalajara Mexico so I changed out pump, coolant hoses, flushed coolant, etc etc.
But others who had the work done- well-- you pay labor and the part. and well it can be as much as $1200 job.
After I did my pump- I called a local dealer and asked how much to change the pump...
his reply after a few minutes was $1125.85

in case you still have an early model Trailblazer- I had made a how to. (pics are on my gallery on that site)
http://forums.trailvoy.com/showthread.php?t=47921&highlight=fuel+pump+%241200&page=11
 

·
Registered
Joined
·
19 Posts
I normally use 94 octane fuel from sunoco(petro canada) in all my cars/truck... it maybe overkill but i never had issues with fuel (knock on wood), my emmission test were always very good compared to other cars. Additives i can't knock them because I never used them, I heard that some brands be it top or low will leave miosture deposits... Now mind you i cant prove it , I just heard through the grape vine .
 
1 - 12 of 12 Posts
Top