Traverse Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello - hope someone can help with this. I have a 2012 Chevy Traverse LTZ with towing package and I do not have any lights in the rear except my backup lights and my top brake light bar. The directionals do not flash and the brake lights and taillights do not light up. This is on both sides of the vehicle. I am thinking it is a fuse or relay but not sure which one or which panel or even where to start looking on this. When I connect the trailer tester, I have all the lights on the tester working but still nothing on the vehicle itself.
 

·
Registered
Joined
·
2,548 Posts
Look in your owners manual (page 10-33 in 2011 manual) under the fuse section and check your fuses. Note that the trailer uses separate fuses from the vehicle, so you want to check the fuses that DO NOT say "Trailer" (or Trlr).
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I did not do anything to check the relays - is there a way to check those as well? I am not sure how I would go about testing the wiring as shown in the diagram
 

·
Registered
Joined
·
481 Posts
Hello - hope someone can help with this. I have a 2012 Chevy Traverse LTZ with towing package and I do not have any lights in the rear except my backup lights and my top brake light bar. The directionals do not flash and the brake lights and taillights do not light up. This is on both sides of the vehicle. I am thinking it is a fuse or relay but not sure which one or which panel or even where to start looking on this. When I connect the trailer tester, I have all the lights on the tester working but still nothing on the vehicle itself.
Just a stupid question. Did you convert the lamps to LEDs? Did you do anything to the vehicle before they stopped working?
Do you have a meter or a 12 volt test light? You can get a cheap unit at an auto parts store. Check fuses for continuity with a meter or with a test light.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
I had the struts replaced last week but that shouldn't have anything to do with this. I took it back to my mechanic and problem solved. As it turns out, the 4 light bulbs failed. Thanks for all the expertise.
 

·
Registered
Joined
·
481 Posts
I thought that one would get the message on the DIC that a lamp was out. All lamps out at once, you should play the lottery. :)
 
1 - 9 of 9 Posts
Top