Traverse Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
New to Traverse world with a 2020 Redline. LED Fogs were eaay to swap as was the led reverse lights , however upon starting the car and driving the lights stay on at a dim rate but no error codes using the Yorkim lights below . Any ideas? Should I go with Lasfit bulbs?
9501
9502
 

·
Registered
2020 High Country
Joined
·
379 Posts
You may have to put a load resistor in the circuit, all those Chinese lights are a gamble no matter what they claim in their ads.
 

·
Registered
Joined
·
248 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Lasfits for the win. While not as bright as the Yorkim's they do the job in making for a unified LED tailend on the Redline. Ill take it for $10.00 . BTW once you figure out how to remove the trim piece what took 20 minutes at first was done in .
 

·
Registered
Joined
·
1 Posts
I need some help new to this forum. I have a 2019 traverse lt and i bought the lasfit reverse lights for it but my rear view camera stays on. Ive seen several people on here say that they all worked good for them but mine didnt. Any suggestions?
 

·
Registered
Joined
·
248 Posts
I need some help new to this forum. I have a 2019 traverse lt and i bought the lasfit reverse lights for it but my rear view camera stays on. Ive seen several people on here say that they all worked good for them but mine didnt. Any suggestions?
This radio has some glitches, IMO.
Mine only did that ONE time after 8 months & 9k miles with them. Turned the car off & then back on, then it was back to normal.

Swap back in your stock bulbs then.
 

·
Read Only
Joined
·
0 Posts
Installed Lasfits months ago and have not has any issues. These are really bright at night compared to the OEM bulbs. I like them a lot.

Thanks Snobrdrdan for the excellent recommendation!
9790
9791
 

·
Registered
Joined
·
24 Posts
I had the issue where once every other day the rear camera would stay on while in Drive. Without the LED reverse bulbs I have no issues. Really liked the LED bulbs too,
 

·
Registered
Joined
·
155 Posts
I had the issue where once every other day the rear camera would stay on while in Drive. Without the LED reverse bulbs I have no issues. Really liked the LED bulbs too,
Too bad - it takes a bit of work to change these out - doesn't it?
 

·
Registered
Joined
·
248 Posts
I had the issue where once every other day the rear camera would stay on while in Drive. Without the LED reverse bulbs I have no issues. Really liked the LED bulbs too,
Mine does that too very randomly (not too often either). I just turn it off & then turn it back on at the first stop light and all is well, if it does happen.
The white & brighter lights outweigh that small/random con, IMO
 
1 - 13 of 13 Posts
Top