Traverse Forum banner

41 - 60 of 75 Posts

·
Registered
Joined
·
162 Posts
Did you clean the throttle body and have you checked the intake tube for oil that's not suppose be there? Plenty of articles on here about and how to.

Sent from my SM-N986U using Tapatalk
 

·
Registered
Joined
·
58 Posts
The issue is most likely the fuel sending unit in the tank. The only other problem it can be, although least likely, is the hpfp is maybe slow to detect the incoming pressure from the in tank pump
 

·
Registered
Joined
·
42 Posts
Discussion Starter #45
@Troublesome3 OK, I thought maybe it was the throttle body. BTW, I didn't have time today because I thought it would be easy, but I need to remove the air filter cover, intake house, and maybe the part the intake hose feeds into. :(
 

·
Registered
Joined
·
162 Posts
Correction on my fuel pressure see image attached. Fuel pressure is around 603psi.


Sent from my SM-N986U using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter #49
Thanks, I'd lik e to get as close a comparison as possible. I'm also not using bluedriver app.
 

·
Registered
Joined
·
162 Posts
Startup was around 1400psi and fluctuating at the fuel rail and around 44-61 at the pressure guage. Ambient temp is 51F°


Sent from my SM-N986U using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter #52
So I think the fuel gauge thing is probably it and not the fuel rail. SO that's actually a little than mine, I guess it must be ok.
 

·
Registered
Joined
·
58 Posts
In my experience dealing with issues like this it has to be a fuel pump issue. When you turn the key and start right away the in tank pump doesn't have time to prime. When you turn the key and wait 2 seconds you are giving the pump time to prime your fuel system up to the hpfp. The hpfp doesn't run if the engine isn't turning. Since the vehicle runs after you've let it prime that leads me to believe it is the in tank pump. If it were a throttle body issue it would effect it while it's running and driving as well as starting. The pump in the tank is just probably getting weak
 

·
Registered
Joined
·
42 Posts
Discussion Starter #54
In my experience dealing with issues like this it has to be a fuel pump issue. When you turn the key and start right away the in tank pump doesn't have time to prime. When you turn the key and wait 2 seconds you are giving the pump time to prime your fuel system up to the hpfp. The hpfp doesn't run if the engine isn't turning. Since the vehicle runs after you've let it prime that leads me to believe it is the in tank pump. If it were a throttle body issue it would effect it while it's running and driving as well as starting. The pump in the tank is just probably getting weak
That stinks. So what should I do? and is there an easy way to check the pump in the tank? How much will a new one cost? I'll probably install it myself.
 

·
Registered
Joined
·
162 Posts
That stinks. So what should I do? and is there an easy way to check the pump in the tank? How much will a new one cost? I'll probably install it myself.
Get yourself a professional diagnosis before you go and throw money at something your not sure of. The last you need is to take the tank down and find other issues which complicate your problem or create a new one.

Sent from my SM-N986U using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter #57
Get yourself a professional diagnosis before you go and throw money at something your not sure of. The last you need is to take the tank down and find other issues which complicate your problem or create a new one.

Sent from my SM-N986U using Tapatalk
I'm trying to avoid going to a mechanic shop. A friend who's a master mechanic said it sounded like the fuel filter and recommended I use B&G 44k Fuel system cleaner.
 

·
Registered
Joined
·
162 Posts
I'm trying to avoid going to a mechanic shop. A friend who's a master mechanic said it sounded like the fuel filter and recommended I use B&G 44k Fuel system cleaner.
B&G is good stuff and it's cheaper than parts and labor.

Sent from my SM-N986U using Tapatalk
 
41 - 60 of 75 Posts
Top