Traverse Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I noticed that the license plates lights weren't working so I put in new bulbs on both sides. Neither bulb worked so I tried two more new ones, still not working. What could cause this? Is there a fuse for them?
 

·
Registered
Joined
·
112 Posts
If you live in a very dusty area like I do you will want to check the lens the bulb attaches to. It may be full of dirt. Of course you would notice the bulb work when you plug it into the socket as long as you have your running lights on, and not on auto during the daytime. I would then verify that the rest of your running lights are working. If they are I would start tracing the wires from the license plate light back up checking your connections for corrosion. If none of the other running lights are working I would check the fuses.
 

·
Registered
Joined
·
563 Posts
Is there a fuse for them?
The license plate lamps are powered by the 10amp left parking light circuit fuse located in the under hood fuse panel. If any of your parking lamps on the left side are out this could be the problem. If those lights are working then the fuse should be good. Fuse is easy to get to so worth pulling out and reseating it or replacing.

Another possibility is a bad ground. Black wire out of the lamp socket is the ground. Both ground wires connect together with trailer wiring(if any) grounds and run to a point on the left side of the body. You will have to follow the wires to the attachment point to check for corrosion or tightness.
 

·
Registered
Joined
·
1 Posts
I have a 2001 Chevy 2500hd truck, problem left rear license plate light was working then it quit. Changed our bulb still did not come on but one on right does work. Took bulb from left and put it on right and bulb works but bulb will not work on left side.
 

·
Registered
Joined
·
7 Posts
Also verify the fuse for the brake lights. I was driving around without the brake lights, only with the upper one. Only noticed when someone told me they were out and realized it is a bad fuse on the fuse box. Had to replace it and kept more fuses with me just in case it goes out again.
 
1 - 6 of 6 Posts
Top