Traverse Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello all! There has been two occurrences where my 2015 Traverse LT AWD completely shuts off while driving. Absolutely everything just cuts out immediately. The engine stops, power bakes & power steering stop working, even the dash and radio go black. Literally everything cuts out. Then, once I am stopped I am able to restart it with no issue.

First time, I was accelerating on the highway when it died and had to pull to the shoulder. The second time I was making a right turn on a city road when the vehicle cut out. This one was scary because when I lost power steering and brakes I could not turn or slow down as I needed to. Thank god there was no pedestrians crossing or cars stopped at the light...as I would have likely hit them.

My two toddlers were also in the car during the second occurrence. I now fear for their safety in our primary family vehicle.

First - Has anyone else experienced this? If so, have you determined what the case was?

Second - Will my airbags still work in the scenario where the vehicle cuts out and causes us to crash?

Thank you in advance for your time & feedback. God bless. -Dave
 

·
Registered
Joined
·
1,403 Posts
First I would stop driving this Traverse before you end up in a big problem causing an accident. The best for you and your family is to bring the car to the dealer and they are equipped to find out what is causing this major issue.
 

·
Registered
Joined
·
4 Posts
Hello all! There has been two occurrences where my 2015 Traverse LT AWD completely shuts off while driving. Absolutely everything just cuts out immediately. The engine stops, power bakes & power steering stop working, even the dash and radio go black. Literally everything cuts out. Then, once I am stopped I am able to restart it with no issue.

First time, I was accelerating on the highway when it died and had to pull to the shoulder. The second time I was making a right turn on a city road when the vehicle cut out. This one was scary because when I lost power steering and brakes I could not turn or slow down as I needed to. Thank god there was no pedestrians crossing or cars stopped at the light...as I would have likely hit them.

My two toddlers were also in the car during the second occurrence. I now fear for their safety in our primary family vehicle.

First - Has anyone else experienced this? If so, have you determined what the case was?

Second - Will my airbags still work in the scenario where the vehicle cuts out and causes us to crash?

Thank you in advance for your time & feedback. God bless. -Dave
I have a 2014 Chevrolet Traverse LTZ AWD .. My Traverse was having intermittent electrical issues and only had 83000km .. after trouble shooting I fond the issue .. it turns out the main issue was the underhood fuse block .. I replaced the whole fuse block .. under $300.00 and all my problems disappeared .. It runs better than ever now
 

·
Registered
Joined
·
6 Posts
Pete in Oshawa is 100 % right !!! The same thing was happening to my wife's 2014 Traverse LTZ and it was the under hood fuse box !!! Change it out before you and the kids get hurt !! You won't regret it !!!
 

·
Registered
Joined
·
11 Posts
Hello all! There has been two occurrences where my 2015 Traverse LT AWD completely shuts off while driving. Absolutely everything just cuts out immediately. The engine stops, power bakes & power steering stop working, even the dash and radio go black. Literally everything cuts out. Then, once I am stopped I am able to restart it with no issue.

First time, I was accelerating on the highway when it died and had to pull to the shoulder. The second time I was making a right turn on a city road when the vehicle cut out. This one was scary because when I lost power steering and brakes I could not turn or slow down as I needed to. Thank god there was no pedestrians crossing or cars stopped at the light...as I would have likely hit them.

My two toddlers were also in the car during the second occurrence. I now fear for their safety in our primary family vehicle.

First - Has anyone else experienced this? If so, have you determined what the case was?

Second - Will my airbags still work in the scenario where the vehicle cuts out and causes us to crash?

Thank you in advance for your time & feedback. God bless. -Dave
Just experienced identical problem on 2012 LTZ (FEBRUARY 2022) 136000 MILES
TZ. Mechanic replaced entire main fuse box under the hood. Was able to duplicate problem by moving fuse box $550 later thought problem fixed and it happened
D again today. Scary feeling and helpless. Like you I put it in park and it started right up and ran 40 miles home and again back to mechanic. He put the test device on and found no codes! He is now calling other mechanics for ideas. WHAT DID YOU DO TO RESOLVE THIS PROBLEM?
 

·
Registered
Joined
·
3,819 Posts
This is a long thread, but you might want to read it all the way through. It's not really the fuse box per se, but one of the pins underneath that appears to be culprit.

 

·
Registered
2015 Traverse LT AWD
Joined
·
258 Posts
Just experienced identical problem on 2012 LTZ (FEBRUARY 2022) 136000 MILES
TZ. Mechanic replaced entire main fuse box under the hood. Was able to duplicate problem by moving fuse box $550 later thought problem fixed and it happened
D again today. Scary feeling and helpless. Like you I put it in park and it started right up and ran 40 miles home and again back to mechanic. He put the test device on and found no codes! He is now calling other mechanics for ideas. WHAT DID YOU DO TO RESOLVE THIS PROBLEM?
People twisted PIN 51 a little and use a washer on the screws to hold the two halves down tight. Missing the washer step would allow the same problem to happen again. Maybe you can give that a try.
 
1 - 8 of 8 Posts
Top