Traverse Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello,

I just bought a 2016 RWD LT Traverse, one of the things i found in the test drive is that when i press the button to wash the front window with washer fluid the fluid comes out the back window but the front wiper blades move, and when i hit the rear washer button the fluid comes out the front and the back blade moves.

my first thought was the hoses got flipped when they did a repair but i cannot see any break in the line from the fluid pumps to the sprayers, so my only guess is that it is a wiring issue at the buttons.....?
 

·
Registered
Joined
·
11 Posts
check the pumps at the reservoir your hoses are crossed lower pump is for the front windshield higher pump is for rear window . sounds like when they did the repair they swapped hoses at the pump . not a wiring issue both plugs for the pumps are different . and can not be swapped good luck
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I switched the hoses at the pumps, all looked OEM so i don't think they replaced anything but no way to tell 100%, was just seeing if anyone else had the same issue or not.
 

·
Registered
Joined
·
777 Posts
I have read that The electrical connectors are so close together that they can get mixed up and placed on the wrong pump.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
the connector that go into the pumps have different connector heads so they can't be switched, same thing with the hoses under the hood, the connectors are different so it is "stupid proof" lol
 

·
Registered
Joined
·
777 Posts
the connector that go into the pumps have different connector heads so they can't be switched, same thing with the hoses under the hood, the connectors are different so it is "stupid proof" lol
OK. So some thought did go into that possibility, good to hear.
 

·
Registered
Joined
·
1 Posts
Same year model. Both front washer assemblies have failed where they attach to the nozzle on the hood within 2 months of each other. It's like the glue in them reached the end of its life. I was able to take the first one out and superglue it back together. I'll be doing the passenger side this weekend.
 
1 - 9 of 9 Posts
Top