Traverse Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Something to watch out for in case you have similar issues. I've had our 2020 Redline for only a few months, and the fake chrome has started bubbling up. It's at the dealer today getting replaced, but I was definitely surprised at having this issue. I hope it doesn't happen again on this or other areas.
8853
 

·
Registered
Joined
·
79 Posts
That had to be caused by some issue when it was manufactured but wow, that's bad. Might be a bad batch out there... I hope mine never does that!
 

·
Registered
Joined
·
1,243 Posts
I have seen this on cars that were on the roads for many years but never so early. Definitely a bad preparation in the process of applying the chrome.
 

·
Registered
Joined
·
113 Posts
If you have the chrome bumper, check your chrome roof racks as well. The exact same issue is on them also.
 

·
Registered
Joined
·
3 Posts
Something to watch out for in case you have similar issues. I've had our 2020 Redline for only a few months, and the fake chrome has started bubbling up. It's at the dealer today getting replaced, but I was definitely surprised at having this issue. I hope it doesn't happen again on this or other areas. View attachment 8853
I had this happen on my 2018 Premier’s roof rails! My Traverse was manufactured in 12/17 and I bought it in 3/18, noticed it about a week after taking it home. They replaced them. Only area I had trouble. Everything still good now.
 
1 - 6 of 6 Posts
Top