Traverse Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2010 traverse Lt model and the drivers window will not work. I have replaced the switch and the window lift motor. There is power at the connector and I have hooked the motor to the rear door and it worked but will not work on the front door. Any ideas?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Figured it out, found a broken ground wire inside the boot of the wire harness between the door and the car body. It was broken in half.
 

·
Registered
Joined
·
11,224 Posts
when I read your post--- thats the 1st thing that came to mind. Broken wire in the rubber sleeve.
 

·
Registered
Joined
·
2 Posts
I have a 2010 traverse Lt model and the drivers window will not work. I have replaced the switch and the window lift motor. There is power at the connector and I have hooked the motor to the rear door and it worked but will not work on the front door. Any ideas?




I have this very same problem only in the summer. I am from MN. In the winter time my driver side window always works. In the summer it is a surprise every time it works, sometimes it gets stuck when I want it rolled down or up. I have switched the motor with a brand new motor and it still didn't work. I has also gone to the junk yard and got a new button panel and that also did not work.
 

·
Registered
Joined
·
2 Posts
I have this very same problem only in the summer. I am from MN. In the winter time my driver side window always works. In the summer it is a surprise every time it works, sometimes it gets stuck when I want it rolled down or up. I have switched the motor with a brand new motor and it still didn't work. I has also gone to the junk yard and got a new button panel and that also did not work.


I have a 2010 ltz
 

·
Registered
Joined
·
2 Posts
Figured it out, found a broken ground wire inside the boot of the wire harness between the door and the car body. It was broken in half.
So I think I may be having the same issue. All 3 of my other windows work from the master switch. Drivers switch, just hear a clicking sound from the switch when pressed. My wife has a 2011 traverse and I swapped out the working switch from hers and my drivers window still didn't work. The weird thing is that when my headlights are on, none of the buttons on my drivers door work except I can still roll down the other 3 windows. Then when I turn the auto headlight switch off, the other switches have power i.e. the door lock, window lock. This makes sense that it could be a ground wire issue. Curious if you experienced anything similar.
 

·
Registered
Joined
·
2,692 Posts
So I think I may be having the same issue. All 3 of my other windows work from the master switch. Drivers switch, just hear a clicking sound from the switch when pressed. My wife has a 2011 traverse and I swapped out the working switch from hers and my drivers window still didn't work. The weird thing is that when my headlights are on, none of the buttons on my drivers door work except I can still roll down the other 3 windows. Then when I turn the auto headlight switch off, the other switches have power i.e. the door lock, window lock. This makes sense that it could be a ground wire issue. Curious if you experienced anything similar.
Have you checked the connector between the door and the body of the car for water? Very common issue. Take the connector apart and dry it out. Put it back together with dielectric grease to help keep water out.
 

·
Registered
Joined
·
2 Posts
I have not tried that yet. Planning on trying to figure it out tomorrow. So would that be in the boot or the chassis side where the moisture would be? Curious to explore this solution. Thanks for the Info. Been driving myself nuts trying to figure it out.
 
1 - 11 of 11 Posts
Top