Traverse Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
994 Posts
Discussion Starter · #1 ·
For awhile now I am noticing the occasional clunking/popping from the front end. I know this is not the ABS check as it happens way after starting a trip and it is a much more noticeable and does sound different.

Any ideas? Could it be the the steering rack? I have not brought it to the dealership as it is not predictably reproducible. Not sure what to do next.
 

·
Registered
Joined
·
272 Posts
I did notice that on mine once when I had about 1k on it. I wonder if its the spring in the strut binding up.
 

·
Registered
Joined
·
994 Posts
Discussion Starter · #3 ·
kawazar said:
I did notice that on mine once when I had about 1k on it. I wonder if its the spring in the strut binding up.
Thanks Rob for the reply. Mine happens daily but not predictably. So taking it to the dealer might not yet be a good use of my time. I am not a mechanic for sure but I am thinking that for example a developing rack problem would be acted on only when hearing the sound consistently.
 

·
Registered
Joined
·
11,568 Posts
I wonder if these have sway bar endlinks....
(on the trailblazers- these were notorious for causing popping or clanking)... sometimes it was as simple as tightening a bolt.
 

·
Registered
Joined
·
11,568 Posts
just saw a post on the acadia forum-
someone there was having clunking issues---
took it in- and they retorqued the front end (parts in suspension I guess).
No more clunking.
 

·
Registered
Joined
·
994 Posts
Discussion Starter · #6 ·
Thanks Barrios for your help in searching out the thread.
 

·
Registered
Joined
·
994 Posts
Discussion Starter · #7 ·
rbarrios said:
I wonder if these have sway bar endlinks....
(on the trailblazers- these were notorious for causing popping or clanking)
I had a Eagle Summit Wagon which went through sway bars like I go through candy. But the noise I am experiencing with the Traverse isnt as loud. Looking at the Encalve forum there is a thread which describes similar noises and it emanated from the steering column. Mine sounds like right at the front end ???.
 

·
Registered
Joined
·
6 Posts
My 2010 Enclave (also Lambba platform) has had this popping since day one. I've adopted a kind of wait and see about it as the only time I have taken it in (for a dead battery) they got my carpet and rear seat fillthy and greasy. Also it just does'nt make the noise loud enough or often enough to justify going through all the BS yet. Chances are the guy would tell me he does'nt hear anything or they will end up making it worse. I just hate service depts. All you get is deer in the headlight looks and patronizing remarks. BTW my popping seems to be associated more with stop and go then with turning although it has occured while in a turn. It's really hard to nail down.
 

·
Registered
Joined
·
994 Posts
Discussion Starter · #9 ·
myrtleman said:
My 2010 Enclave (also Lambba platform) has had this popping since day one. I've adopted a kind of wait and see about it

BTW my popping seems to be associated more with stop and go then with turning although it has occured while in a turn. It's really hard to nail down.
I have yet to take it into the dealership. As far as I can tell there is no reproducible pattern to the clunking or popping. Its weird. And so for sure the dealership wont acknowledge the problem. Let us know if you ever do do something about it.
 
1 - 9 of 9 Posts
Top