Traverse Forum banner

1 - 20 of 78 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hey all!

I have a 2012 traverse lt with 27,000km.

Today when I got home here is what happened: check engine light, traction control message, engine power reduced message and effective. Called the dealer right away, they said to bring it in tomorow morning...hope I can make it to the dealer.

Also hope they fix it quickly and for good...I'm leaving from Montreal to Florida in 2 weeks...scarry!!!

Let you all know the problem and fix they did...

Magi.
 

·
Premium Member
Joined
·
1,662 Posts
Hi Magi!

Please keep us posted on your dealership visit. I hope things are resolved for you before your trip! Let me know if further assistance is needed.

Jessica
Chevrolet Customer Care
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Here I am back from dealer. It ended up beeing a loose connector and some dirt in the fuel line (or some sort)...at first I was not too certain about the diagnosys, but after talking to one of the mechanics, he mentionned not to be worried for my trip...

My fingers will be crossed for the hole trip that nothing goes wrong.

Thanks Jessica for keeping track!
Let you know if assistance is needed

Magi.
 

·
Registered
Joined
·
154 Posts
I just had the same thing happen to mine today. The codes I pulled said P0700, which talk on the forums suggest a waveplate or the transmission control module being bad...

Dropping it off first thing Monday morning at the dealers to see what's going on with it.
 

·
Premium Member
Joined
·
1,662 Posts
Hi SimonTuffGuy,

Please keep us posted on your dealership visit! If further assistance is needed, please let me know.

Jessica
Chevrolet Customer Care

SimonTuffGuy said:
I just had the same thing happen to mine today. The codes I pulled said P0700, which talk on the forums suggest a waveplate or the transmission control module being bad...

Dropping it off first thing Monday morning at the dealers to see what's going on with it.
 

·
Premium Member
Joined
·
1,662 Posts
You're welcome, Magi! Have a safe trip.

Jessica
Chevrolet Customer Care

magi said:
Here I am back from dealer. It ended up beeing a loose connector and some dirt in the fuel line (or some sort)...at first I was not too certain about the diagnosys, but after talking to one of the mechanics, he mentionned not to be worried for my trip...

My fingers will be crossed for the hole trip that nothing goes wrong.

Thanks Jessica for keeping track!
Let you know if assistance is needed

Magi.
 

·
Registered
Joined
·
4 Posts
Exact same issue I have had. Just joined and scanning the forums have found this same issue in several different locations.
Seems to be a real flaw with the GM vehicles.
I replaced the throttle position sensor first and the problem came back the next day.
Replaced the entire throttle body next and has been good for a week. No warranty and no help from GM dealer.
Now my tire pressure sensor alert is on even though all tires are up to pressure, and all show good pressure on the display!
What next!!
 

·
Premium Member
Joined
·
1,662 Posts
I am sorry about the issues you have experienced with your vehicle! Please private message me with your full contact information, VIN, and mileage, and I can get you in contact with the proper department to assist. Thank you!

Jessica
Chevrolet Customer Care

vhjkindopp said:
Exact same issue I have had. Just joined and scanning the forums have found this same issue in several different locations.
Seems to be a real flaw with the GM vehicles.
I replaced the throttle position sensor first and the problem came back the next day.
Replaced the entire throttle body next and has been good for a week. No warranty and no help from GM dealer.
Now my tire pressure sensor alert is on even though all tires are up to pressure, and all show good pressure on the display!
What next!!
 

·
Registered
Joined
·
97 Posts
I'm an old tech (59 with 24 yrs in AF) and in general do not like Multi-function devices. When a single function fails you lose the entire machine when it goes in for service. Our LT1 is the first new car we've had since 2001 and before getting it I really questioned the integrated systems, but you don't have much of a choice now a days. Still, there is no valid reason for everything to go through the EMC.
 

·
Registered
Joined
·
1 Posts
My 2012 Traverse with 26,000 miles just went crazy, first a message engine power reduced and it felt like my trans went into 1ST, almost immediately a check stabilitrak message flashed. I have a very important job I need to be at tomorrow! Can anyone give me advice? Can I drive it to a dealer?
Thanks!
 

·
Registered
Joined
·
2 Posts
I sadly just experienced this with my 2011 Traverse LTZ tonight. Driving home with my 3 children in the car ... no warning ... just beep beep beep ... traction control off - service traction control - service stabilitrack - engine power reduced! It was the scariest thing because it was like the vehicle shifted into the lowest gear and I could not drive over 10 mph!
I got pulled over and immediately called my local dealer. The service department did not immediately act like the issue was something that they were familiar with, but offered to take the vehicle in first thing tomorrow morning.
I took the car to a local Oreily's and had them run the code. P0221 - for Throttle Position Sensor 2 Performance. Possible fixes were Engine Control Module (ECM) and Throttle Body replacement.
I logged on to the good ole web this evening and decided to do some research myself ... i.e. possible recalls or any forum advice. I have unfortunately seen nothing but large problems with this issue. It seems as though this has been an issue with traverse modules all the way back to 2009 when the module was initially introduced. There may have possibly been a recall on 2010 models but nothing for 2009, 2011 - present.
I am taking my vehicle in to the dealer in the morning and am hoping to have swift resolution ... however, most people say that the problem comes back even after having things replaced.
Chevy/GM .... really need to consider a better way to serve their customers in regards to this issue. This problem - whatever it may be - is NOT SAFE! To have a vehicle reduce engine power out of nowhere while driving is hazardous to the consumer as well as other drivers on the road!
Good luck!
 

·
Registered
Joined
·
11,499 Posts
SGTGAB said:
My 2012 Traverse with 26,000 miles just went crazy, first a message engine power reduced and it felt like my trans went into 1ST, almost immediately a check stabilitrak message flashed. I have a very important job I need to be at tomorrow! Can anyone give me advice? Can I drive it to a dealer?
Thanks!

If youre handy- Id give the throttle body a real good cleaning (spray and move the valve.).
see if that helps....

been seeing lots of these on the forums with the now severe cold weather in many parts.
 

·
Registered
Joined
·
2 Posts
WOW
this really seems to be an issue.
our 2011 Traverse with 36500 (ish) miles started doing this last month. now its doing it regularly.

As far as I am reading I see there is no known issue or should I say no positively know issue.
when will this get resolved. I havent taken it in to the dealer yet because of the horror stories I am hearing and hopefully I didnt make a mistake now that I have over 36k miles on it (i dont know the in service date yet)

I am calling the dealership today but if anyone has any input on this repair keep us posted!
 

·
Registered
Joined
·
97 Posts
boatn70 said:
WOW
this really seems to be an issue.
our 2011 Traverse with 36500 (ish) miles started doing this last month. now its doing it regularly.

As far as I am reading I see there is no known issue or should I say no positively know issue.
when will this get resolved. I havent taken it in to the dealer yet because of the horror stories I am hearing and hopefully I didnt make a mistake now that I have over 36k miles on it (i dont know the in service date yet)

I am calling the dealership today but if anyone has any input on this repair keep us posted!
If you're just barely out of warranty call GM and have them document it. Then keep on the dealer about getting it fixed, don't let them stall you. Every mile you put on that vehicle means less chance you'll get help from GM (or less help you'll get if you get any).
 

·
Registered
Joined
·
3,231 Posts
GM's recalling their small cars for a similar loss of power problem, but it's tied to your key ring. Seems like the Traverse problem would rank a bit higher on the priority scale.

http://www.impomag.com/news/2014/02/gm-recalling-nearly-780000-compact-cars?et_cid=3767613&et_rid=220182084&type=cta

Maybe there aren't enough Traverse drivers bitching as the small cars. They must have sold a lot more Cobalts and G5's than Traverses.

Toyota's having a similar problem, and they're recalling:

http://www.impomag.com/news/2014/02/toyota-recalls-294000-vehicles?et_cid=3767613&et_rid=220182084&type=cta

I guess Traverse owners just don't rate.
 

·
Registered
Joined
·
49 Posts
I got the same problem last week. Hard shift into 2nd gear and then really reduced power. The CEL came on too. Had to limp home about a mile. Hooked up the diagnostic tester and got a p0700 and p0717. Reset the light and the fault went away. It's been 3 days without another fault. When it comes back the dealer will be checking it out.
 

·
Registered
Joined
·
17 Posts
Have posted the whole history of my related issues on another thread.

Summary: New 2014 AWD LS Traverse with 97 miles on it. At day of delivery had issues. Issues continued. Module replaced. Deemed defective, replaced. Deemed defective, replaced. Entire wiring gone through. Total of 4 modules have been installed, under 1900 miles on it and still having issues. I immediately went to the top, emailing outline of everything experienced since day of delivery to the dealership owner on down the line of managers. Dealership General Manager went to Chevrolet. Chevrolet has approved buy back w/o my needing to secure a lawyer (Lemon Law). I was persistant but remained polite, more flies with honey line of thinking, and Assistant GM and my original salesman are working on finding me a replacement as I write this.

Flukes happen but it doesn't mean you have to just suck it up and accept it. Be the squeaky wheel, no pun intended.

Good luck everyone!!
 
1 - 20 of 78 Posts
Top