Traverse Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Alright, so at 6580 miles, the Traverse still said I had 50% oil life left. I can't see driving that far on dino oil (or any oil for that matter) so I decided it was time for an oil change. After reading all the "oil change" topics and replies I set out on what I thought was going to be the biggest pain in the @$$ oil change ever. Don't get me wrong, it wasn't easy and I did end up making quite a mess.

Before starting, I pulled the Traverse up onto Rhino ramps. I then placed a large piece of cardboard under the vehicle where I thought the oil would drop. Since the Traverse uses the same oil filter as my '07 Avalanche, I was able to use the same oil filter removal tool. This is the one that looks like a large socket and attaches to a 3/8" ratchet. It was a tight fit and I did bang my knuckles and pinched my upper arm a bit but I was able to get enough leverage on the ratchet to get the filter off. After reading the other posts, I tried to create a "catch can" out of an old windshield washer bottle to catch the oil that leaked out but it didn't work. Still got oil everywhere. The rest was uneventful...removed the filter, drained the oil, put new filter on, filled with oil, CLEANED UP MESS!

Has anyone some up with a way to change the oil without making such a mess? What about an oil filter relocation (I don't even know if such a thing exists)?

Anyway, just thought I would give my impressions and observations from my first try at changing the oil in my Traverse. I went ahead and switched to Mobil 1 5W-30 fully synthetic and used an AC Delco filter just as I have in my past 4 GM vehicles.

I just don't know how GM could have done such a good job on the 5.3L V-8 engines as far as oil filter and oil drain placement and such a lousy job on this engine. Heck, the H3 I briefly owned even had a little plastic catch guard thing with a drain spout. Still made a mess but at least it seemed as thought GM thought about it a little.
 

·
Registered
Joined
·
46 Posts
I left the car on rhino ramp this past Saturday and the oil filter loose overnight before I changed the oil & filter Sunday morning. There was not mess. Only little oil visible on the cast aluminum engine bracket. No oil elsewhere.
 
1 - 2 of 2 Posts
Top