Traverse Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
The driver side brake light, turn signal light is out and the bulb is fine. I'm not getting power to the socket at all. The side light in the door mirror is not working either. I'm wondering if these are connected to each other. If that light is out on the mirror would that cause the brake light and turn signal to not work at all? It seems to me that the brake light should work independently from the turn signals but I'm no electrical wizard for sure. Any suggestions would be appreciated a lot. Everything on the passenger side is working fine.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I thought I would also add that the front park lamp on that side is working and I have power at the rear socket for my tail lights, just not for the brake/signal light.
 

·
Registered
Joined
·
2,862 Posts
Check the fuses in the underhood fuse and relay box and the instrument panel box (under passenger side dash). See your owners manual for names and locations.

You don't say what year you have. Fuses start around page 10-32 in the 2011 owners manual.

You should have RT PRK (right parking), LT PRK (left parking) in the underhood box. These will pick up parking lights, tail lights and side marker lights.

You should have LT/TRN/SIG, RT/TRN/SIG and BCK/UP/STOP fuses in the instrument panel box. The first two pick up the turnsignal/brake on each side and the 3rd picks up the backup lights and center brake light.
 
1 - 3 of 3 Posts
Top