Traverse Forum banner

21 - 40 of 40 Posts

·
Registered
Joined
·
4 Posts
They finally fixed mine and the issue was a camera module and the front camera. When it would work the front facing camera never did work. Not sure if water was getting into camera through the grille and shorting module.
We bought our 2020 premier on the first of the year. Been having the issue on and off for the entire time of ownership. Very intermittent for us so hasn’t been worth taking to the dealership just for them to say, “looks fine to me!” But after seeing this forum with others having the same issue I might decide to take it in. Maybe they will issue some sort of fix for it. Hopefully because my wife really loves her Traverse. Located in California.
 

·
Registered
2020 High Country
Joined
·
10 Posts
They finally fixed mine and the issue was a camera module and the front camera. When it would work the front facing camera never did work. Not sure if water was getting into camera through the grille and shorting module.
Any details or part number on that camera module so I can reference it with our dealer?
 

·
Registered
Joined
·
1 Posts
We purchased a 2020 Traverse and after 3 weeks the back up. Camera went black with a triangle symbol. Took it in for service and now 3 weeks after service it is happening again. 3500 miles on it and now in for second time. Has anyone else had a similar experience?
Yes this is happening to my 2020 Chevy Traverse with 1000 miles. Now at 2500 miles same thing. I keep doing the factory reset it works for then back to the malfunction. The Chevy dealer told me that they’ve never seen that problem before.
 

·
Registered
Joined
·
21 Posts
We purchased a 2020 Traverse and after 3 weeks the back up. Camera went black with a triangle symbol. Took it in for service and now 3 weeks after service it is happening again. 3500 miles on it and now in for second time. Has anyone else had a similar experience?
YES, bought A new 2020 Traverse Premier in March 2020. The very next day the backup camera went black like you explained but also has a pink screen that comes up. Has been to dealership where purchased 6 times and last time it was there. They kept it 9 days and went to pick it up and the backup camera came on. Stopped at store maybe 3 min later and put in R and black screen again. The techs tore my new traverse apart and didn’t put it back together right and scratched 2 large scratches in paint on back lift gate. Grease all over the interior, panels they took apart arent put back in correctly.,such a night mare to spend that kind of money on a new 2020 Chevy Traverse Premier loaded and have this kind of problems with it bc the tech doesn’t know what hes doing evidently . The wiring is messed up and things go haywire on the radio backup mirrors don’t go down some times and then they don’t come up other times. They totally acted like my new traverse was a junker while they worked on it evidently the last 9 days it was in shop and treated it like crap. It has scratches all over the interior also. I could go on and on but, I’m not. It gets lots worse. Good luck.
 

·
Registered
Joined
·
1,362 Posts
The less you visit the dealers the better.
 

·
Registered
Joined
·
1 Posts
We purchased a 2020 Traverse and after 3 weeks the back up. Camera went black with a triangle symbol. Took it in for service and now 3 weeks after service it is happening again. 3500 miles on it and now in for second time. Has anyone else had a similar experience?
We just purchased ours about 2 weeks ago and having the same problem. Any update if your camera is working now?
 

·
Registered
2020 High Country
Joined
·
10 Posts
We just purchased ours about 2 weeks ago and having the same problem. Any update if your camera is working now?
No one has posted an actual solution or TSB. I was on the phone with GM for 3 hrs, got bounced around 4 different depth,Our dealership won't look at it until it fails there.
 

·
Registered
Joined
·
1 Posts
I have been back and fourth to the dealership and that is want would happen to me that it would work fine so they would not do anything but the service rep said at least it is documented that there is an issue with the back up camera
We bought our 2020 premier on the first of the year. Been having the issue on and off for the entire time of ownership. Very intermittent for us so hasn’t been worth taking to the dealership just for them to say, “looks fine to me!” But after seeing this forum with others having the same issue I might decide to take it in. Maybe they will issue some sort of fix for it. Hopefully because my wife really loves her Traverse. Located in California.
 

·
Registered
2020 High Country
Joined
·
10 Posts
I finally made enough noise with our local dealership to get this looked at by Chevy/GM engineering.
Our Chevy Service Manager found a TSB on Cadillac having similar issues with the backup camera and asked me to bring the Traverse in to check for failure codes (which it had) and to re-flash the video control module in the rear, behind the driver side panel. The software flash did not work due to chipset compatibility with the boot-loader. GM engineering ended shipping a new video control module and it is scheduled for replacement on 12/23. If this works, I will post the TSB in reference (hopefully Chevy Traverse is added to the list) and details with the video module that was replaced. https://static.nhtsa.gov/odi/tsbs/2020/MC-10175749-9999.pdf
 

·
Registered
Joined
·
21 Posts
They finally fixed mine and the issue was a camera module and the front camera. When it would work the front facing camera never did work. Not sure if water was getting into camera through the grille and shorting module.
They still have not fixed mine. They’ve supposedly installed two new backup cameras, a new module and still didn’t work the last time I left. Took it back Dec 10,20. Been in shop 11 days. Received call this morning from dealer .said they had to order new parts for my 2020 Chevrolet Traverse Premier. Don’t know what they’re replacing now. I guess they’ve torn up bunch more things like before that they never got fixed back. The electric to all safety system doesn’t work since last time it was there. Had to call GM Priority Care but they wasn’t much help. Said it was GM Priority but answered as Chevrolet. Told me to take back to dealer one more time and see if they could fix it. Been there 11 days. Loaned us a little 2020 equinox for 11 days. This morning received call that they had to order new parts and it’d be a few more days in shop. This evening received a call from tech and said he was sending someone out to pick up Equinox and bring me another vehicle. Didn’t give me a chance to go fuel it back up. Was at my home in 25 min. Brought a brand new 2021 GMC Acadia with 23 miles on it for me to drive. A black one at that. My 2020 Chevy Traverse premier is metallic black also but all leather , dual sunroofs. Mine is loaded. This 2021 is ok but still not my Chevy 2020 traverse Premier. This is 8th time in shop for same backup came but the dealership deleted all the times that my new traverse had been in the shop in 4 months and only put one time and it’s a date that my traverse has never been in the shop there. They put Oct 31,2020 and put electrical problems , nothing about backup camera and that’s bn whole problem until they tore everything apart from front to rear trying to trace down a shortage. Never found it and still no camera. It’s a shady dealership or otherwise why would they hide all the times it’s been in the shop and put a date on my history of times it been to shop to only one date and it’s not even been there on that date. What does it sound like to everyone else. Sounds like they trying to cover their butts their but I have all proof and pics of times it’s been to shop but they deleted on my Chevrolet app?? Wonder why? Has this happened to anyone else?? Attorney time!
 

·
Registered
2020 High Country
Joined
·
10 Posts
After 2 weeks the issue has gone away with a new video control module. I will keep this thread updated if the issue returns.
 

·
Registered
Joined
·
345 Posts
They still have not fixed mine. They’ve supposedly installed two new backup cameras, a new module and still didn’t work the last time I left. Took it back Dec 10,20. Been in shop 11 days. Received call this morning from dealer .said they had to order new parts for my 2020 Chevrolet Traverse Premier. Don’t know what they’re replacing now. I guess they’ve torn up bunch more things like before that they never got fixed back. The electric to all safety system doesn’t work since last time it was there. Had to call GM Priority Care but they wasn’t much help. Said it was GM Priority but answered as Chevrolet. Told me to take back to dealer one more time and see if they could fix it. Been there 11 days. Loaned us a little 2020 equinox for 11 days. This morning received call that they had to order new parts and it’d be a few more days in shop. This evening received a call from tech and said he was sending someone out to pick up Equinox and bring me another vehicle. Didn’t give me a chance to go fuel it back up. Was at my home in 25 min. Brought a brand new 2021 GMC Acadia with 23 miles on it for me to drive. A black one at that. My 2020 Chevy Traverse premier is metallic black also but all leather , dual sunroofs. Mine is loaded. This 2021 is ok but still not my Chevy 2020 traverse Premier. This is 8th time in shop for same backup came but the dealership deleted all the times that my new traverse had been in the shop in 4 months and only put one time and it’s a date that my traverse has never been in the shop there. They put Oct 31,2020 and put electrical problems , nothing about backup camera and that’s bn whole problem until they tore everything apart from front to rear trying to trace down a shortage. Never found it and still no camera. It’s a shady dealership or otherwise why would they hide all the times it’s been in the shop and put a date on my history of times it been to shop to only one date and it’s not even been there on that date. What does it sound like to everyone else. Sounds like they trying to cover their butts their but I have all proof and pics of times it’s been to shop but they deleted on my Chevrolet app?? Wonder why? Has this happened to anyone else?? Attorney time!
Did you ever contact Chevrolet Customer Care and get them involved? You were advised to do that 6 months ago, yet you have never acknowledged that you did so. There are POSITIVE steps YOU can take to get it resolved. Use ALL the tools that are available to you. Hammer the dealer thru corporate. Use the lemon law. This forum doesn't have leverage, but those avenues do; use them!
 

·
Registered
Joined
·
21 Posts
Yes I Did contact Chevrolet Customer care and GM Priority care. The man at GM priority care wasn’t too Friendly or nice. He was really rude just to be honest but He told me take my Traverse back to the dealer which this makes 8 times. The date on the message that you’re referring to was back in June 4, 20, not Dec.10,20 like I’d written. I hadnt taken it back to the dealership since June, not until GM told me to take it back one more time to start the process. I really hated to take it back to the dealership bc of all the damage they’ve already done to the 2020 Traverse. The Dealership erased all the times that my Traverse had been in the shop there for some reason. They deleted every time it had been in the shop and put only one time. The date that was put on the computer was in August and my Traverse had not been in the shop at all in August. Guess they’re trying to cover up all the times they’ve messed my traverse up but I have the proof on Messages and have a cpl invoices and only 1 work order they gave me back in March 2020. My Chevrolet App could be pulled up and I could see everything but now it only shows the date in August 2020, which is a lie. This makes 8 times that my Traverse has been in shop and they’re showing only 1 time plus this time, they’ll have to notate I assume. This is 26 days that it has been in shop and the dealership has had a different tune this time after all the times it’s been in shop there. They’ve practically torn it all to pieces though and I just pray that I don’t have to take that Traverse back bc it’s basically a totaled vehicle bc of the dealership. I was afraid to even drive it anywhere bc of the electric messed up and none of the safety features work since the last time it was there in June for the 9th day. I can’t see anything that’s on My Chevrolet App like before. I’m so upset and angry. I just wish u people could see the pics and videos that I’ve taken each time after getting the traverse back and the backup camera still never worked. They said they have put 2 new cameras in traverse and also a module back in June but never changed any of the performance of the Traverse. So sad to be paying for something that stays in the shop more than it does at my home.
 

·
Registered
Joined
·
345 Posts
Do you still have your copies of the work orders/service sheets? Make copies, send them to Chevrolet Customer Care and work with one of the supervisors at Customer Care--not one of the phone reps; document, document, document! Make notes of date, time, who you speak with, etc. and advise them what the system currently shows versus the files and copies of work orders that you have. Provide them substantiated proof that the dealer is attempting to pull a fast one; they can't argue with hard evidence. All else fails, contact a lawyer and provide him with the facts and details--along with copies of your files. Contact the Better Business Bureau and file a complaint; contact your local TV station if they have a consumers action hotline. Work with factual information with each of those agencies; unscrupulous businesses can't withstand the light of publicity and knowledge of their actions--in their local community nor within their corporate world.
 

·
Registered
Joined
·
21 Posts
Do you still have your copies of the work orders/service sheets? Make copies, send them to Chevrolet Customer Care and work with one of the supervisors at Customer Care--not one of the phone reps; document, document, document! Make notes of date, time, who you speak with, etc. and advise them what the system currently shows versus the files and copies of work orders that you have. Provide them substantiated proof that the dealer is attempting to pull a fast one; they can't argue with hard evidence. All else fails, contact a lawyer and provide him with the facts and details--along with copies of your files. Contact the Better Business Bureau and file a complaint; contact your local TV station if they have a consumers action hotline. Work with factual information with each of those agencies; unscrupulous businesses can't withstand the light of publicity and knowledge of their actions--in their local community nor within their corporate world.
 

·
Registered
Joined
·
1 Posts
We purchased a 2020 Traverse and after 3 weeks the back up. Camera went black with a triangle symbol. Took it in for service and now 3 weeks after service it is happening again. 3500 miles on it and now in for second time. Has anyone else had a similar experience?
[/HiQUOTE]
Yes, we bought a 2020 Traverse Premier in March 2020. It has been to dealership twice and backup camera still goes to black screen with an X over camera and a (!) mark. then will change to a pink screen scrolling up and down. Does this Almost everytime when Traverse is put in Reverse. very aggravating buying Brand New Chevy Traverse Premier and backup camera keeps malfunctioning. the mirrors turn down when in Reverse but backup camera messes up everytime it’s driven. Only has barely 1500 miles on it. Has anyone else had this problem ?
Hi we bought a new 2020 Chevy Traverse LT loaded and had same problem deal said they could not replicate problem.So when it happened the next time I opened the rear hatch and closed it.And it corrected the problem.Through my deductive reasoning I believe it is something in rear hatch is loose or a poor design.Try it hope it helps you as well.
 

·
Registered
Joined
·
21 Posts
Yes, I have what copies I was given. I wasn’t given a copy of work order or invoices on most occasions and I didn’t really think a lot about it because I never dreamed anything like this would happen, but I did have to sign each time I received a loaner when the traverse was put in shop. That should also show up there at Crossroads Chevrolet. They have lied to GM telling GM that the traverse backup camera worked fine while it was there at shop because they said they watched it for several days. Lol, they never moved it but once from dealership. It was driven 2 miles. That’s one time it was moved in 41 days. They left wiring lying in rear seat that we assume goes to the backup camera. It’s just laying out in the open and runs down in front of 3rd row seat to the floor panel on middle seat at door on passenger side. The floor panel at door wasn’t even put back on correctly. The wire then comes back out in front of front passenger seat and goes up into glove box. They also broke something on glove box because when opening the glove box, it just falls open and nothing catches it like it did before taking it back Dec 9,2020. The backup camera did come on Jan 19,2021 when we backed up from leaving dealership but had already noticed a lot of extra damage that the techs had caused to Traverse during 41 days it was at dealership. There’s big brown spots on the top interior in the back near back hatch, looks like it had leaked while at dealership. They also had torn up the seal that goes around the rear hatch around the top of the glass. It was just hanging down in places all across top of hatch glass. Looks like someone just tried to push the seal back in place but evidently used something sharp bc they damaged the seal and it wasn’t damaged on the Saturday evening when we was called to pick it up but was still hanging down like it had been since June 12, 2020. I pointed it out to the salesman that sold us the traverse bc he’s the only person there that we are allowed to communicate thru. The Sales Manager hasn’t spoken to us except on one occasion and that was June 12, 2020 when we picked up traverse and noticed the big scratches in the black paint on the back hatch bc we was walking to the traverse with sales Mgr and approached it from the back. I Ask sales Mgr what happened to the scratches on the hatch back which he’d stopped maybe 20 feet before traverse and pointed to our traverse. I had to speak loud for him to hear bc he act like he couldn’t hear. I yelled the second time and finally he just threw his hand up and said he didn’t know. I ask him to come look at it and he just said. “ I have no idea what happened and he just kept walking back toward building. That was first time ever seeing the sales Mgr. Anyways we was told to leave the traverse on 1-16-21 and pick it up Monday 1-18-21. That’s when the salesman and we noticed the seal around the back hatch had been torn up since Saturday , just 2 days before . It wasn’t torn up but was not put in correctly. We also noticed the big brown spots on the top of interior and the salesman told us himself that if he was us, he’d take the new traverse to a different dealership bc the techs there didn’t know what they were doing and evidently didn’t care. I do have a pic of his hand on the dark spots on the interior roof where it looks awful and ruined. It’s getting moisture inside of it also bc the techs didn’t put anything back together correctly when they were sup to have installed 3 new backup cameras and 2 modules but GM doesn’t show that any of that work has been done . I have the paperwork that shows that they replaced 3 backup cameras and 2 modules. Also they were suppose to have installed a new backup camera and new module in June but it never worked if they did. Also the rearview back up mirror camera didn’t work when we picked it up on 1/18/21. It’s sickening as to what the Chevrolet/GM dealership in Corinth Ms has done to a 2020 New Traverse Premier. All because they were sup to have been tracing down shortage in the coax cable from backup camera but just tore everything up. I’ve bn talking to GM Priority care / Chevrolet customer care and they keep putting us on hold and hanging up and never getting back to us. I’m sick of messing with GM/Chevrolet both.
 
21 - 40 of 40 Posts
Top