Traverse Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
We purchased a 2020 Traverse and after 3 weeks the back up. Camera went black with a triangle symbol. Took it in for service and now 3 weeks after service it is happening again. 3500 miles on it and now in for second time. Has anyone else had a similar experience?
 

·
Registered
Joined
·
259 Posts
I don't have as many miles on my 2020 as you have on yours, but I haven't experienced any problems at all--none as you describe.
 

·
Registered
Joined
·
16 Posts
We purchased a 2020 Traverse and after 3 weeks the back up. Camera went black with a triangle symbol. Took it in for service and now 3 weeks after service it is happening again. 3500 miles on it and now in for second time. Has anyone else had a similar experience?
We purchased a 2020 Traverse and after 3 weeks the back up. Camera went black with a triangle symbol. Took it in for service and now 3 weeks after service it is happening again. 3500 miles on it and now in for second time. Has anyone else had a similar experience?
Yes, we bought a 2020 Traverse Premier in March 2020. It has been to dealership twice and backup camera still goes to black screen with an X over camera and a (!) mark. then will change to a pink screen scrolling up and down. Does this Almost everytime when Traverse is put in Reverse. very aggravating buying Brand New Chevy Traverse Premier and backup camera keeps malfunctioning. the mirrors turn down when in Reverse but backup camera messes up everytime it’s driven. Only has barely 1500 miles on it. Has anyone else had this problem ?
 

·
Registered
Joined
·
259 Posts
2020 traverse Premier--I haven't experienced any problems with my cameras on our Premier. May I suggest another trip to your dealer and have them perform diagnosis? If it does it almost every time, shouldn't be difficult for them to observe. If they aren't willing to properly diagnose, call Chevrolet Customer Care and get them involved. Make the dealer's Service Department do their job. (In my state--Texas--3rd visit for same problem, you could start process of "lemon law" action; that usually gets dealer's attention if nothing else does. Last resort.)
 

·
Registered
Joined
·
16 Posts
2020 traverse Premier--I haven't experienced any problems with my cameras on our Premier. May I suggest another trip to your dealer and have them perform diagnosis? If it does it almost every time, shouldn't be difficult for them to observe. If they aren't willing to properly diagnose, call Chevrolet Customer Care and get them involved. Make the dealer's Service Department do their job. (In my state--Texas--3rd visit for same problem, you could start process of "lemon law" action; that usually gets dealer's attention if nothing else does. Last resort.)
Yes, I’m gonna take it back again. The last time I took it back. They sent me off in a loaner and kept mine. Later that evening around 4:30 the man over service called and said that they would have to keep my traverse overnight bc they had to order a part and it wouldn’t be in until the next morning . They told me that itd be ready around 10am the next day . I received a call the next morning at 9:00 am. The service Mgr said that my traverse wouldn’t be ready until later in the evening. I got a call at 5:15pm saying my 2020 Chevrolet Traverse was ready and I could come get it. The salesman that sold me my traverse drove it up to front of dealership after about 30 min and he didn’t have to walk but approximately 50-60 ft. Couldn’t see him from where we was tho. After he brought it back to me, he said it’s ready to go. My little girl and I got in. I put traverse in R and the black screen came up first thing and then the pink screen. I immediately text the salesman's cell and told him that I havent even backed out of parking space that he parked it in and the black screen and the pink scrolling screen is all that’s still showing I’m backup camera. He had already pulled out of dealership heading home . I started videoing my backup camera screen when I put it in R and it kept doing same thing. I told my little girl to keep videoing and take some pics. I get home and pickup up the invoice that was in my traverse stated: Customer stated that Radio keep going in and out. They showed that they replaced something in the AM/FM radio, lol. I took several videos into the dealership the first and second time I took traverse back and let the service mgr watch it and the General Mgr while standing in shop office. Lol, I do not know where or how they came up with saying I told them that my radio still wasn’t working when I took them the videos and pics on 3 different days when I had driven the traverse. Im still wondering what kind of part did they order for the AM/FM radio, lol, when nothing was ever wrong with the AM/FM radio in the first place. It played fine with no problems bfr whatever part they supposedly ordered and replaced in the AM/FM radio. They knew it was my backup camera. The backup camera wasnt messing up quiet as bad when I took it back the last time but it’s gotten worse each time I’ve driven the Traverse Since and it still has less than a 1000 miles on it. I’m about to get angry with those people there. I’ve been very patient with them soo far and you can see what it has accomplished. Nothing but inconvenience bc of having to keep going back and still not fixed.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Yes, we bought a 2020 Traverse Premier in March 2020. It has been to dealership twice and backup camera still goes to black screen with an X over camera and a (!) mark. then will change to a pink screen scrolling up and down. Does this Almost everytime when Traverse is put in Reverse. very aggravating buying Brand New Chevy Traverse Premier and backup camera keeps malfunctioning. the mirrors turn down when in Reverse but backup camera messes up everytime it’s driven. Only has barely 1500 miles on it. Has anyone else had this problem
Yes, we bought a 2020 Traverse Premier in March 2020. It has been to dealership twice and backup camera still goes to black screen with an X over camera and a (!) mark. then will change to a pink screen scrolling up and down. Does this Almost everytime when Traverse is put in Reverse. very aggravating buying Brand New Chevy Traverse Premier and backup camera keeps malfunctioning. the mirrors turn down when in Reverse but backup camera messes up everytime it’s driven. Only has barely 1500 miles on it. Has anyone else had this problem ?
Now on our third fix, they tell us its a coaxial cable which has been on order for over a month. As of the 9th of May it will be in the shop for 2 months.
Yes, I’m gonna take it back again. The last time I took it back. They sent me off in a loaner and kept mine. Later that evening around 4:30 the man over service called and said that they would have to keep my traverse overnight bc they had to order a part and it wouldn’t be in until the next morning . They told me that itd be ready around 10am the next day . I received a call the next morning at 9:00 am. The service Mgr said that my traverse wouldn’t be ready until later in the evening. I got a call at 5:15pm saying my 2020 Chevrolet Traverse was ready and I could come get it. The salesman that sold me my traverse drove it up to front of dealership after about 30 min and he didn’t have to walk but approximately 50-60 ft. Couldn’t see him from where we was tho. After he brought it back to me, he said it’s ready to go. My little girl and I got in. I put traverse in R and the black screen came up first thing and then the pink screen. I immediately text the salesman's cell and told him that I havent even backed out of parking space that he parked it in and the black screen and the pink scrolling screen is all that’s still showing I’m backup camera. He had already pulled out of dealership heading home . I started videoing my backup camera screen when I put it in R and it kept doing same thing. I told my little girl to keep videoing and take some pics. I get home and pickup up the invoice that was in my traverse stated: Customer stated that Radio keep going in and out. They showed that they replaced something in the AM/FM radio, lol. I took several videos into the dealership the first and second time I took traverse back and let the service mgr watch it and the General Mgr while standing in shop office. Lol, I do not know where or how they came up with saying I told them that my radio still wasn’t working when I took them the videos and pics on 3 different days when I had driven the traverse. Im still wondering what kind of part did they order for the AM/FM radio, lol, when nothing was ever wrong with the AM/FM radio in the first place. It played fine with no problems bfr whatever part they supposedly ordered and replaced in the AM/FM radio. They knew it was my backup camera. The backup camera wasnt messing up quiet as bad when I took it back the last time but it’s gotten worse each time I’ve driven the Traverse Since and it still has less than a 1000 miles on it. I’m about to get angry with those people there. I’ve been very patient with them soo far and you can see what it has accomplished. Nothing but inconvenience bc of having to keep going back and still not fixed.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Now on our third fix, they tell us its a coaxial cable which has been on order for over a month. As of the 9th of May it will be in the shop for 2 months.
[/QUO
Now on our third fix, they tell us its a coaxial cable which has been on order for over a month. As of the 9th of May it will be in the shop for 2 months.
What state are you in, we are NH
 

·
Registered
2020 High Country
Joined
·
6 Posts
We have a 2020 Traverse High County and experience a similar issue. We did notice our issue was based on outside temp. When in the garage or cooler temps 40 to 75 F, no issues, when the Traverse sits outside on a hot day, 80+, we experience issue where the camera doesn't work. Anyone identify a real root cause of the problem and a known fix from GM or Chevy?
 

·
Registered
Joined
·
16 Posts
We purchased a 2020 Traverse and after 3 weeks the back up. Camera went black with a triangle symbol. Took it in for service and now 3 weeks after service it is happening again. 3500 miles on it and now in for second time. Has anyone else had a similar experience?
My 2020 Traverse Premier has been to the dealership 6 times and has never worked but maybe one time when putting in Reverse and hasnt worked since. picked it up first time and put in R and no camera leaving dealership. Called dealership Sales Mgr and he told me call them bk the next week. I did but it was still 2 weeks bfr they could give me appt. my traverse has been at dealership in shop more than its been at home. Such ashame.
 

·
Registered
Joined
·
16 Posts
My 2020 Traverse Premier has been to the dealership 6 times and has never worked but maybe one time when putting in Reverse and hasnt worked since. picked it up first time and put in R and no camera leaving dealership. Called dealership Sales Mgr and he told me call them bk the next week. I did but it was still 2 weeks bfr they could give me appt. my traverse has been at dealership in shop more than its been at home. Such ashame. Id only had my New Traverse Premier 3 days when it started showing the black screen and then a pink screen kept coming up also. There needs to be a recall on the 2020 Traverse bc after dealership traces wires and takes all panels off bc of backup camera, they scratchled panels up and put all on totally wrong. Disgusting!!
 

·
Registered
Joined
·
16 Posts
2020 traverse Premier--I haven't experienced any problems with my cameras on our Premier. May I suggest another trip to your dealer and have them perform diagnosis? If it does it almost every time, shouldn't be difficult for them to observe. If they aren't willing to properly diagnose, call Chevrolet Customer Care and get them involved. Make the dealer's Service Department do their job. (In my state--Texas--3rd visit for same problem, you could start process of "lemon law" action; that usually gets dealer's attention if nothing else does. Last resort.)
My Traverse has been in the shop for same problem at least 6 times. Still not working. State of Mississippi
 

·
Registered
Joined
·
16 Posts
They have done the diagnostics on my Premier. They also saw that the camera only worked one time while in shop. They said they put new module and a new backup camera on my 2020 Traverse premier. Then tech said the camera went out again while at shop. They said there was a shortage in cable to backup camera. They tore my traverse apart and ruined the panels bc of tracing wiRed. Still no backup camera and they want me to bring it back again. Nope!! Been there done that too many times over past 3 months. Do not buy from Crossroads ever!
 

·
Registered
Joined
·
259 Posts
Get in touch with Chevrolet Customer Care. Formalize the complaint with them--get a case number. They can intervene and correct the situation at the dealership so it doesn't happen to someone else. They can also set you up with another dealership. Contact them--they can do something where we are just a sounding board for you.
 

·
Registered
Joined
·
4 Posts
They have done the diagnostics on my Premier. They also saw that the camera only worked one time while in shop. They said they put new module and a new backup camera on my 2020 Traverse premier. Then tech said the camera went out again while at shop. They said there was a shortage in cable to backup camera. They tore my traverse apart and ruined the panels bc of tracing wiRed. Still no backup camera and they want me to bring it back again. Nope!! Been there done that too many times over past 3 months. Do not buy from Crossroads ever!
Did the dealer figure it out?
 

·
Registered
Joined
·
16 Posts
Gotcha. Just bought a 2020 premier and stopped working on the way home.
Yea, that stinks. Do not let them keep trying to fix backup camera bc they will tear your traverse up. They take panels from inside all the back inside panels and panels on back hatch. They have over 1/2” gap on panels on hatch. Scratched up paint job bad. my New 2020 Traverse Premier is a piece of junk since they have messed the wiring up In it also. Electric back up mirrors don’t work right now, iPhone won’t sync with radio even if it’s plugged in with usb cord. Terrible. Still NO BACKUP CAMERA after 4 months. The corona halted shop for weeks but they dI’d not know what they was doing at all!!
 

·
Registered
2020 High Country
Joined
·
6 Posts
Our dealership ran the codes after the camera failed, low voltage detection. I won't authorize any work until GM issues a tech bulletin on root cause and fix. No trial and error for some tech to tear the car apart. If it is low voltage, that means cable is too thin, low quality for the HD camera to send a good signal Like using a cheap HDMI cable on 4k TV. Waiting for the cooler months as we are logging the failures.
 

·
Registered
Joined
·
1 Posts
We bought our 2020 premier on the first of the year. Been having the issue on and off for the entire time of ownership. Very intermittent for us so hasn’t been worth taking to the dealership just for them to say, “looks fine to me!” But after seeing this forum with others having the same issue I might decide to take it in. Maybe they will issue some sort of fix for it. Hopefully because my wife really loves her Traverse. Located in California.
 
1 - 20 of 30 Posts
Top