Traverse Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
2016 Traverse. This was an issue when I bought it and the Dealer had to fix it. That was two months ago. The problem returned tonight. Cools great in recycle but outside damp air in regulars mode. Calling them tomorrow but was interested in ideas of what might be the problem. Thanks in advance.
 

·
Registered
Joined
·
241 Posts
Think about it. Do U have central air in your house? If so, in the summer do U open the front door or the windows to pull in outside air when the A/C is on?..........Basically a retorical question.

As I have stated before, whether it's a house central unit or a car A/C, 1/3rd. of it's capacity is for latant work IE: humidity control. Have a 4 ton heat pump central unit, which in August, which it R right now, it's removing several gallons of humidity(water) per hour outta my humble abode. Can hear water running down the A/C drain.

One can imagine introducing outside air & humidity into the controlled space what it would do.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
Except for the fact that it was working fine up to the point it stopped I don't see the relevance of your answer. Thanks but...
 

·
Registered
Joined
·
241 Posts
Am in the habit of posting "er reverent" answers.....If I were you, I wouldn't read my posts.
 

·
Registered
Joined
·
241 Posts
BTW, still have my "beloved" 97 Plymouth Grand Voyager with 283k miles. Put 1 1/2 cans of R134 in it total. Will hang icicles of your ear lobes.

Only problem, bout 1 1/2 years ago I decided to fix it.....it wasn't broken. Changed all the sensors & timing chain.

Ain't run since then. Gonna get back on it this winter.

OMT, don't tell anyone about this...OK?
 
1 - 6 of 6 Posts
Top