Traverse Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So this morning I got in the traverse and the eagle eye/rear camera stopped working. Anyone else having this issue? Super annoyed but nothing I can do but take it to the dealer. The one thing I noticed when checking the fuse box under the hood was that most of the fuses were half way out of the sockets/holder. I found that pretty strange. I’ll keep you guys posted!

8809

8810
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
:UPDATE:

Radio won’t shut off when vehicle is shut off, driver door open and alarm set. Takes a few minutes to shut off. Remote start doesn’t work either. Traverse is going to the dealer on Monday ......
 

·
Registered
Joined
·
116 Posts
Maybe pull the neg. battery cable off for a reset?

All the electronics have a mind of their own. My '19 radio wouldn't respond to the station paddle switches - went into work and they were functional again when I went out for lunch.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4 (Edited)
Maybe pull the neg. battery cable off for a reset?

All the electronics have a mind of their own. My '19 radio wouldn't respond to the station paddle switches - went into work and they were functional again when I went out for lunch.
Funny thing you mentioned that. The traverse has some sort of parasitic drain, cause it wouldn’t even start tonight. When I went to jump it with the Duramax, it was sparking from the ground terminal on the chassis. I moved the jumper directly to the battery. As soon as it started I moved the jumper from the negative terminal to the ground terminal on the chassis and everything was normal. When getting inside I got a whole lot of errors. After reviewing my cameras, no attempt of theft was made on her.

Every vehicle manufacture has its issues but this is a major electronic failure that needs to be documented and addressed. With out a doubt this will cause major issues down the road. It’s not if, it’s when. This Issue has the potential to cause harm or death. I wouldn’t ever think Chevy bad quality but after my Duramax having potentially major problems with the CP3 fuel pumps failing. If not under warranty, the damages will be 10k-12k. Handful of other issues, now this with the traverse. I’m losing faith in Chevy
8822

8823

8824

8825

8826

8827
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
So s
OMG - that's equivalent to the "Blue Screen of Death" on a PC!
came back from our camping trip, started the traverse and everything is back to normal, including eagle eye/cameras. So **** weird. System must have reset after the battery died. Going to the dealer tomorrow, even though they will tell me. “Sorry we couldn’t recreate the issue, please come back when it happens again”
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Like I have mentioned before, they couldn’t recreate the issues. Said I had a bad battery and wasn’t driving it enough. Replaced battery. Not happy but at least it’s documented here
 

·
Registered
Joined
·
436 Posts
I was going to suggest it could be a bad battery. It happens unfortunately and batteries can cause all kinds of crazy things to happen.

My general rule of thumb is when you start having more than 1 weird electrical issue, replace the battery first.
 

·
Registered
Joined
·
5 Posts
My wife's 2020 Traverse back up/ eagle eye cameras have been acting up as well. Sometimes it works great, next time same screen as you had above with the exclamation point and camera crossed out. Dealer "Couldn't recreate it", but it has happened again quite a bit since. Suppose it will be going back when we can leave it so they can dig deeper. Frustrating on a new vehicle!
 

·
Registered
Joined
·
5 Posts
Hey Jeeebz, did you ever get the issue with your camera solved? Did the new battery help the camera? My wife's doesn't work 80% of the time now.
 

·
Registered
Joined
·
1 Posts
2020 High Country. Had it since Monday, 2/25. Have had this camera issue twice, but all fine after leaving it off for awhile. I'll probably just count the occurrences and mention it at the 1st oil change...
 

·
Registered
Joined
·
5 Posts
That is what we did as well, and they weren't able to recreate it supposedly. Didn't work when my wife left the dealership. They said if it kept doing it we would have to bring it back when they had more time to troubleshoot it. Not easy for us to go without this vehicle (two infant seats and one booster seat) but looks like we are going to have to take it in and leave it.

Post back if you find anything out when you have yours looked at.
 

·
Registered
Joined
·
4 Posts
That is what we did as well, and they weren't able to recreate it supposedly. Didn't work when my wife left the dealership. They said if it kept doing it we would have to bring it back when they had more time to troubleshoot it. Not easy for us to go without this vehicle (two infant seats and one booster seat) but looks like we are going to have to take it in and leave it.

Post back if you find anything out when you have yours looked at.
 

·
Registered
Joined
·
4 Posts
My 2020 Traverse Premier is having backup camera problems since day 1 of purchasing vehicle. Only has 299 miles on it now and it has been to shop twice for same problem. I video recorded the backup camera while it was put in R. A pink screen keeps coming up and then the black screen showing no camera. Has anyone else had this problem. Taking back to dealership because I’ve already sent the videos of the backup camera messing up several times. Can’t use backup camera hardly ever and new traverse only has 299 miles on it.
 

·
Registered
Joined
·
4 Posts
My wife's 2020 Traverse back up/ eagle eye cameras have been acting up as well. Sometimes it works great, next time same screen as you had above with the exclamation point and camera crossed out. Dealer "Couldn't recreate it", but it has happened again quite a bit since. Suppose it will be going back when we can leave it so they can dig deeper. Frustrating on a new vehicle!
Video it with cellphone when it does that. My new 2020 Traverse Premier is doing the same thing except a pink screen comes up on the backup screen, then the black screen again. Just keeps changing from black screen to pink screen but can’t use back up camera. The next time it might work good. I videoed mine doing this several different days. Only 299 miles on my new Traverse.
 

·
Registered
Joined
·
5 Posts
Haven't had the pink screen yet, but still having the black screen with the no camera sign. My wife has taken pictures of that. We are hoping to get it in to the dealership again this spring. Keep us updated if you get yours in and worked on.
 

·
Registered
Joined
·
4 Posts
Video it with cellphone when it does that. My new 2020 Traverse Premier is doing the same thing except a pink screen comes up on the backup screen, then the black screen again. Just keeps changing from black screen to pink screen but can’t use back up camera. The next time it might work good. I videoed mine doing this several different days. Only 299 miles on my new Traverse.
Ok, yes I’m sup to take it in at 9am in the morning.
9066
 
1 - 19 of 19 Posts
Top