Traverse Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
We have a 2018 Redline Traverse with 24000 miles on it. It has started saying "shift to park" on the screen even when it is in park. When this happens we cant lock it and it sits there and dings. Can get it to go off by wiggling the shifter but it is getting worse. Any ideas?
 

·
Registered
Joined
·
5 Posts
Shift to park

This just started happening to my 2018 Premier the past few days! 19,000+ miles. Took it to dealer this am, needs new shifter and he said he's ordering the bezel because most do not survive the replacement. I know its an issue that needs repair because to happened to my daughter's 2016 (redesigned model) Malibu last year! And there was a 2018 at the dealer waiting for the bezel from its shift to park repair!
 

·
Registered
Joined
·
13 Posts
I had it happen very early on my 2017 Acadia and it was a problem for months while GM tried to find a solution. Eventually an entire new shifter assembly was installed, updated part number, and the problem disappeared. There are 8 pages of people with that issue on the Acadia forum, all but one was corrected by the new shifter assembly.
 

·
Registered
Joined
·
289 Posts
This started happening to mine 3 weeks ago. I went to the dealer who said they had fixed it.

Had to return a second time to the dealer because this time I couldn't get it to stop at all.

A service technician came over, pulled on the shift-lock moved the shifter a bit and it stopped beeping.

They ordered a new shifter assembly and replace it last Friday. Guess what happened when I got home... yep! did it again.

I recorded a video so that everyone at the dealership that needs to know will be able to see it themselves.

Just sent an email to the service manager with a link to the video and asked him to call when they are ready for me again.

Here is the link to the video. Thought some of you would like to see it. For those to whom it's happened already, this will be very familiar.

 

·
Registered
Joined
·
1 Posts
2018 Traverse 'Shift to park'

Hello - My 2018 Traverse had shift to park alert two weeks ago. I brought the Traverse into the dealership on 7/9/19 and I was told that day that they were ordering the replacement part - new gear shift. Its now 7/21 and still - the part is not in. As mentioned by others, the part is not available in the US with no ETA. Frustrating.
 

·
Registered
Joined
·
2 Posts
Thanks for posting this. Our 2018 with 30K just started this “Shift to Park” problem today. I’ll be taking it to the dealer tomorrow.... I’m glad we bought the extended warranty, we still have 70K for them to get it right ??
 

·
Registered
Joined
·
2 Posts
I was surprised. I dropped my Traverse off at the dealer today and they had a shifter in stock. They replaced it in a single day and I picked it up this afternoon. I’ll update this thread as it unfolds.
 

·
Registered
Joined
·
1 Posts
We have been having the same problem and getting worse. I am taking to dealer on Monday. In the mean time has anyone figured out how to get it to stop beeping? At first I could jiggle the shifter and it would stop, but now sometimes it wont stop.
 

·
Registered
Joined
·
2 Posts
I was surprised. I dropped my Traverse off at the dealer today and they had a shifter in stock. They replaced it in a single day and I picked it up this afternoon. I’ll update this thread as it unfolds.
This is a pretty common problem for these. I see them at least a few times every month. The replacement isn't that hard, Just takes a little finesse.

There is a bulletin which you can look up that will give you more information.
#18-NA-297: Message Displaying Shift to Park when in Park - (Apr 12, 2019)
The cause of the condition may be the park switch in the transmission control (shifter) assembly not pulling BCM signal low to electronically show Park condition.
Repair : Replace the transmission control (shifter) assembly.
 

·
Registered
Joined
·
1 Posts
My 2018 Traverse, with less than 24,000 miles. has been at the dealer for over a week. I was told that due to the UAW strike, they did not know when the part would be available. Not real happy at the moment.
 

·
Registered
Joined
·
1,701 Posts

Another GM fix on the cheap. Problem is in the switch contained in the shifter assembly so clean the contacts in the switch and put in a stub connector with new contacts on the old cleaned contacts on the switch which caused the problem in the first place. Just a wild pessimistic guess but that cleaning may last just long enough until the warranty expires. Lucky for me that crapo press together switch broke when I brought the car for installation of the stub connector.....lucky me....then they had to give me a new improved shifter assembly with a modified switch likely with new contacts that don't need a periodic cleaning.


They pulled the same crap with me on my '16 Silverado with a mechanical vacuum pump failure causing hard braking when the aux electric vacuum pump couldn't provide enough boost. First they were replacing with new improved mechanical vacuum pumps under a TSB and extending the warranty to 60K on the part, then came no more expensive mechanical pump repairs,instead a software update to cycle the electric backup more frequency to compensate for the loss of vacuum output at the main pump. Bye bye '16, rather have a '19 with a
 

·
Registered
Joined
·
1,701 Posts
.02 This is my favorite part of the repair:...."Next, clean the Park Switch electrical contacts by depressing the actuation rod fully and then releasing the rod. Use the flat side of a trim stick or your thumb and allow the rod to “snap” back to the full up position. (Fig. 35) Repeat the cleaning procedure 50 times. It’s critical to clean the electrical contacts to ensure a proper repair."


If the finish on my car requires me to wash it 50 times in a row to get it clean.....tells me if won't stay clean for long and what I really need is a new car.
 

·
Registered
Joined
·
1,303 Posts
Time to place the order. Lol
 

·
Registered
Joined
·
1 Posts
My traverse just have this issue yesterday. I tries all kind of way to fixed it. Somehow I able to made it stop with the error gone. I thought maybe I fixed it, but this morning my wife took my kids to school. She called me and told the error shows again. I was not home so I told her to just leave the vehicle on. Whenever I get back I will take a look. Otherwise I have to call the dealer. Do a research and came across this forum, and it looks like I have to take it the the dealer. Wow, this is a pain.
 

·
Registered
Joined
·
5 Posts
On our 2018 premier w/ 23k miles we just had our first "Shift to park" message appear this past weekend once. Then last night it occurred 2 more times. After already being familiar with the issue from reading this forum I knew it would only get worse. So called in for a service appt at 5pm, and got in for a 10am slot the next day. They confirmed the issue and performed the latest wire harness addition, and mentioned if the issue continues the next step would be to replace the shifter assembly.

Does anyone know exactly what the harness does? Does the added length take pressure off a plug or does it serve as some electrical/signal conditioning?

It seems to be working now, but will definitely be watching it before the warranty expires.
 
1 - 20 of 38 Posts
Top