Traverse Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
We bought a fully loaded 2018 Traverse in February 2018 and paid nearly $65,000. We love the car: it’s size, features and seating layout. Perfect for us and the 3 kids. In around August we experienced a strange problem where when parked in our driveway (very slight incline) the parking brake wouldn’t disengage. My wife was 7 months pregnant and couldn’t get the car to move. I thought she might me mistaken so didn’t think too much about it. Eventually after shutting down the engine for awhile it worked. About two months later the gear shifter acted up: when parking the car, and putting the shifter in ‘park’ and attempting to power down the car it wouldn’t recognize it was in ‘park’ and wouldn’t shut the computer off. We would turn the car off and on a few times and shift from ‘park’ to ‘drive’ a bunch of times and eventually it would take. I took it to the dealer and they said it was a known issue ( the gear shifter) and replaced components for free ( warranty). I also mentioned the parking break issue and the said it was probably related. A few weeks later the parking break issue happened to me: I was stuck in park and couldn’t move. Triple A and Chevy roadside assistance advised a series of shifting and restarting; nothing would get the car out of ‘park’. Eventually we disconnected the battery which reset the car’s computer. Problem was gone. Took it to dealer who didn’t know what to do. A few weeks later, happened again. Took to dealer and called Chevrolet to report and they checked connections and replaced nothing. Driving the car now but expect this to happen again soon. Next time I will have the car towed in while parking brake is stuck so that they can see the problem for themselves.
 

·
Registered
Joined
·
1,703 Posts
Gear shift is a separate issue.



Check your automatic parking brake on the rear wheel assembly.......black cover might be the problem with water intrusion shorting out the electrics.....later models

retrofitted with a blue cover to prevent this.



If it has a black cover and it happens again, no need to tow, disconnect the battery....see the dealer and show the bulletin below
Explained in detail:


https://sandyblogs.com/techlink/?p=10173
 

·
Registered
Joined
·
2 Posts
I had the same experience with my 2018 Traverse LT. The parking brake would not disengage. I took it to the dealer in which they could not reproduce the problem I experienced. The parking brake issue happened again about 3 months ago but I have not taken it back to the dealership again. We have not used the parking brake since then but I feel that we should so the problem can be fixed.
 

·
Registered
Joined
·
1 Posts
My parking brake just came on while I was stopped for red at traffic light. When tried to go, couldn’t go. Brakes were locked. Finally got it to move enough to get off 3 lane highway in to a parking lot. Turned ignition on and off several times. Message came up that said, “service parking system. Dismiss came up so did that and could go. The indicator light (P) with a wrench under it came up. At dealership for 5 days. Don’t think fixed because (P) indicator comes up. Have not gotten car back yet, but say they need to drive it they distance, time had driven when happened. Won’t feel safe driving it.
 

·
Registered
Joined
·
866 Posts
My parking brake just came on while I was stopped for red at traffic light. When tried to go, couldn’t go. Brakes were locked. Finally got it to move enough to get off 3 lane highway in to a parking lot. Turned ignition on and off several times. Message came up that said, “service parking system. Dismiss came up so did that and could go. The indicator light (P) with a wrench under it came up. At dealership for 5 days. Don’t think fixed because (P) indicator comes up. Have not gotten car back yet, but say they need to drive it they distance, time had driven when happened. Won’t feel safe driving it.
I hope they gave you a free loaner. Sounds like they don't have a clue and they probably are not dedicating a lot of time trying to fix it for you.
 

·
Registered
Joined
·
1 Posts
My parking brake get blocked when I turn on the car Message came up that said, “service parking system. Dismiss came up so did that and could go. The indicator light (P) with a wrench under it came up. At dealership they could not find out the problem and Don’t fixed .
I think this is car problem they have to fix.
 

·
Registered
Joined
·
1 Posts
My park brake & wrench light keeps coming on, along with the display message. I asked the Dealer to look into it after the first time and they shrugged it off (wasn't showing at the time). It happened after I put the car in AWD. Now it's happening a little more consistently. I press dismiss and it doesn't seem to alter the function of the car. The car is in AWD more due to Michigan Winter. Hoping to see some solutions.
 

·
Registered
Joined
·
1 Posts
I had the same issue with my 2018 AWD LT. The driver panel said service parking brake. I tried several times to disengage the parking brake without success. After the vehicle was off for about 15 minutes I started the engine and was able to disengage the brake.
 

·
Registered
Joined
·
9 Posts
I had the same issue with my 2018 AWD LT. The driver panel said service parking brake. I tried several times to disengage the parking brake without success. After the vehicle was off for about 15 minutes I started the engine and was able to disengage the brake.
My 2018 High Country with ~46k miles just recently experienced this same issue. The first time it happened I had been stopped to talk with a friend for a good 10 minutes (but I didn't engage it in park, I was idling the entire time). When I started driving, I got maybe 100 yards and the parking break engaged itself. It would not disengage and the driver panel said 'service parking brake'. I had it towed (though after about 15 minutes of engine off it did eventually disengage) because I didn't feel safe driving it. They claimed it was a faulty switch, they changed it out, reprogrammed it and sent me on my way. Tonight, about a month later, I was sitting idle for a good 5 minutes at a long red light and it again engaged on it's own, this time I was able to 'dismiss' the message that it was on and when I pressed on the gas pedal it disengaged. I wonder if this auto-engagement has anything to do with being in idle (not parked) at length. Can anyone relate? Before a month ago I had never experienced anything like this.
 

·
Registered
Joined
·
1 Posts
I had the same issue with my 2018 AWD LT. The driver panel said service parking brake. I tried several times to disengage the parking brake without success. After the vehicle was off for about 15 minutes I started the engine and was able to disengage the brake.
Going thru this now.
 
1 - 10 of 10 Posts
Top