Traverse Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
We have a 2018 Traverse that the sound has stopped working for a second time. The first time it came back after a day. This time it has been out for 3 weeks. Had the dealership look at it today after verifying that all the fuses were good. The dealership want to replace the ANC Module for $620. In the forum I have not seen this mentioned as a solution? The quote says”replace radio ACN module to re-evaluate concern”. This seems like an expensive step that is not guaranteed to solve the problem. Car is barely out of warranty. Was well under the first time it acted up. Any thoughts?
 

·
Registered
Joined
·
720 Posts
This is probably what the dealer is referring to as a possible cause and remedy. If the problem is the Module due to the Condensation issue, make sure they put the shield in. Ask them if it is the cause or are they just throwing parts at it. Did you bring it to the dealer the first time it happened and if so, was it under warranty?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
This is probably what the dealer is referring to as a possible cause and remedy. If the problem is the Module due to the Condensation issue, make sure they put the shield in. Ask them if it is the cause or are they just throwing parts at it. Did you bring it to the dealer the first time it happened and if so, was it under warranty?
My wife did not take it in since it started working fine the day she was going to schedule it for service. It was fine then for a year.
 
1 - 3 of 3 Posts
Top