Traverse Forum banner
1 - 3 of 3 Posts

·
Registered
2019 Premier FWD
Joined
·
146 Posts
On my 2019 Premiere the USB/3.5mm module allows Android Auto/Apple Car Play to the infotainment system. They also allow a USB media device to be played through the infotainment system.

With that in mind there must be a USB wire missing from that back USB mini jack.
 

·
Registered
2019 Premier FWD
Joined
·
146 Posts
I found this service procedure:
I think this confirms that a USB connector is missing from the back of your jacks (X83 below) and connects to the K74:

"Verify the USB cable is properly connected at all components and in-line connections, and there is no damage to the cable or connections. If connection problems or cable damage is noted. Perform the appropriate repair or replacement to correct any issues. Go to next step: If no connection problems or cable damage is noted.
5. Connect the X1 harness connector at the X83 Auxiliary Audio Input.
6. Disconnect the vehicle USB cable harness connector at the K74 Human Machine Interface Control Module and the X83 Auxiliary Audio Input Adapter.
7. Connect the EL-50334 - 14 Infotainment Test Cable and the EL-50334 - 2 Type-A Female to Mini-B Male Cable together. Connect the assembled test cable to the K74 Human Machine Interface Control Module and the X83 Auxiliary Audio Input."
 

·
Registered
2019 Premier FWD
Joined
·
146 Posts
Locator:
K74 Human Machine Interface Control Module
In the passenger compartment, right side of the instrument panel, behind the instrument panel compartment.
 
1 - 3 of 3 Posts
Top