Traverse Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Has anyone else with a 2015 traverse experienced this? Now mechanic is saying timing chain has jumped and I need new motor!
 

·
Registered
Joined
·
11,174 Posts
Did your check engine light come on?
Yes- head to an auto parts store- like Autozone and have someone there scan the codes for you. Write them down.

No- if he told you it jumped with no check engine light.. or scanning for codes.. I would probably run away from him. fast

These messages can actually pop up for a whole lot of things- that sometimes are not even related to the engine.
Its weird how these come up.
so yes, please post any codes and folks can jump in and give suggestions.
With just those messages- we would literally be guessing,

I see in one picture your CEL is on-- in the 2nd it is off.

so yes- scan for set or pending codes
 

·
Registered
Joined
·
4 Posts
I just had the same issue on my 2009 Traverse. Trying to find out if the timing belts can be replaced and if it is cost effective to go that route. It had been a great car with minor issued until this. Ron
 

·
Registered
Joined
·
4 Posts
I just had the same issue on my 2009 Traverse. Trying to find out if the timing belts can be replaced and if it is cost effective to go that route. It had been a great car with minor issued until this. Ron
no codes or check engine light. Doesnt shift right and can only get to 45 mph.. Any suggestions would be appreciated.
 

·
Registered
Joined
·
551 Posts
Ron. The truck has Timing Chains not belts, they are expensive to replace. Usually with a bad chain, stretched chain or a skipped tooth you would get a CEL.
How many miles do you have, how often do you change the oil and what kind of oil do you use. Has the Throttle Body been cleaned?
 

·
Registered
Joined
·
1 Posts
I just bought a 2009 traverse in January having the same issues with the traction control I'm waiting on parts for other codes
In researching problems with traction I found it has 5 speed sensors 4 on the wheels 1 on the transmission has anyone tried replacing or cleaning the speed sensor on the transmission
 

·
Registered
Joined
·
551 Posts
I haven't heard of anybody replacing the transmission speed sensor. I have heard about codes generated due to the mismatch of engine output VS transmission speed.
What other codes are you getting?
 

·
Registered
Joined
·
4 Posts
Ron. The truck has Timing Chains not belts, they are expensive to replace. Usually with a bad chain, stretched chain or a skipped tooth you would get a CEL.
How many miles do you have, how often do you change the oil and what kind of oil do you use. Has the Throttle Body been cleaned?
185,000 miles no cell, every 3,000 miles always at the dealer.
 
1 - 11 of 11 Posts
Top