Traverse Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, we have a 2011 traverse that won't start. We replaced the starter because it was cooked. We even put a new battery but still nothing. When we turn the key over and try cranking it the engine light flashes rapidly and we hear a series of clicks. We have checked all fuses and relays and everything is fine. We tested the new starter and it works. Someone said it could be anti theft system or a problem with the ignition? help please!!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Re: 2011 traverse won't crank over...but the battery isn't dead.

Anybody have any idea what's going on with this thing??? So frustrated!!! Last year at this time the motor went with only 70000kms on it...now this has happened...wondering if I didn't get a lemon?
 

·
Registered
Joined
·
118 Posts
If you have replaced your starter and battery the next thing I would think of with your symptoms would be a bad ground.
 

·
Registered
Joined
·
9 Posts
Did you ever get this fixed. My 2010 has the same issue and the engine light flashes rapidly as well. I have tested and see that there is no voltage going the starter switch wire, the positive has 12 volts.
 

·
Registered
Joined
·
1 Posts
did you ever get the no start problem with your traverse figured out... I have a 2009 that's basically doing the same thing... we got the car as a bank repo after about 5 -
6 weeks we had to get a engine replacement, now it's only going on 8 months later and the car works fine one day then the next day it won't crank over to start, battery show to have good charge, all fuses and relays look good, I haven't checked the starter out yet but then again I'm not really sure how to even get to the starter.... can anyone help me with this problem.... Thanks
 

·
Registered
Joined
·
11,435 Posts
you have to remove the front CAT to get to the starter.
may want to start spraying the nuts/bolts with penetrating stuff.
 

·
Registered
Joined
·
1 Posts
Hi. I had a similar proble. Today with our 2011 Traverse. Died on my girlfriend while driving. Thankfully it started for her and made it home to save me crazy repair bills. When she pulled in the driveway she saw a puff of smoke and heard some noise. When I got home from work would not turn over at all even with jump cables. Battery was fully charged and capable. To me is sounded like the engine wanted to turn over but the car was stopping it from trying. Ended up pulling off the belt found the ac compressor to be locked tight. Hopefully this will save you guys some money.
 

·
Registered
Joined
·
1 Posts
I so need som help please. I got a 2010 traverse and for the last week sometimes it would start and other times I would have to jump it off. So today I jumped it off to go get a new battery. Needless to say I didn't make it. On my way there my car just quiet going down the road. I tried to jump it back off and it wouldn't start back. I got a tow home and got a ride to get a new battery. I had the battery put in and still nothing. So I tried to jump it off again thinking maybe its the alternator but still nothing. Please someone tell me what to do. I'm desperate!
 

·
Registered
Joined
·
3,143 Posts
You're not alone.

 

·
Registered
Joined
·
11,435 Posts
familygal38.
It could possibly be a bad relay.
In the fuse box in the engine compartment... theres is a relay called CRNK.
look at the number on the relay.
There are I think 2 more relays with that number. One is for the rear defroster. Take them out- and swap them.
Now see if it starts.

the relay used for cranking- may have gone bad. If it does click- its possible that enough (stuff) has built up on the contacts.
Stuff--- cant remember the name- but its black looking stuff that builds up on contact points after time.
 
1 - 11 of 11 Posts
Top