Traverse Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My 2010 traverse won’t start after ecm & starter has been replaced sent it to the dealer only for them to say it’s the ecm but I already replaced that can somebody plz point me in the right direction as to what’s the next thing to try
 

·
Registered
Joined
·
6 Posts
Just curious.. I heard of this in the past.. not sure about about newer ones.. Did you have the ECM reprogramed before you installed it ?
 

·
Registered
Joined
·
11,572 Posts
I thought the same.
ECM may have to be programmed with vehicles VIN etc.
 

·
Registered
Joined
·
14 Posts
Just because the ECM came pre programmed doesn't mean it's just going to be installed and start right up. Let me ask you this... When you try to start and turn the key, is the anti theft security device on? Does it flash a msg about it on the info screen at the instrumentation panel? There is a light on panel that has a picture of a car and a lock on it as well. When you get a new ECM even if it's pre programmed by flagship you have to relearn the anti theft device system. If you haven't gone through the steps, let me know and I will share a link to them.
 

·
Registered
Joined
·
14 Posts
The vehicle won't start until you go through the process of relearning the anti theft device associated with the ecm and your vehicle. The ECM was programmed with your vin but your vehicle doesn't know that. It just knows a new device took the place of your old ecm so to speak. Here is a pdf with the instructions so you can once again start your vehicle.
 

Attachments

1 - 8 of 8 Posts
Top