Traverse Forum banner

41 - 58 of 58 Posts

·
Registered
Joined
·
23 Posts
I just encountered the no speaker issue today driving to work. Although they were working initially at first, 6 miles into the commute, the left front and rear went out, except for the A pillar. Right side is fine. I've had the car since new 2011 model bought July 2010. Looking through the posts it tends to be moisture/water related. Its going to be 90+ degrees today so will check after work see if the hot weather dries up the issue. Normally it's garage kept but its been out for the last few weeks while on vacation.
 

·
Registered
Joined
·
23 Posts
UPDATE: As previous posts have commented, I too had water in the body to door wire harness. The harness has a pull down clip in which you can easily remove to check for water. Once the sun heated up the car the speakers came back. I only found water in the rear left door. Eventually it happened the next day (no speaker issue). So I decided to test the left speakers and found they were blown as hooking up another speaker did work. I remember my kids saying one of the rear speakers wasn't working while ago. I think the front one ended up blowing too. So I had both problems occurring at the same time, water in the harness and blown speakers. I replaced all 4 door speakers with Pioneer 6 1/2" 3 ways to run off the factory head unit and keeping the factory tweeters in the A pillars. Also needed for the install was speaker mounts and wire adapters since I didn't want to cut up the factor speakers and wires if I ever decide to put them back in (ie; trade in).

Links to parts used:
https://www.bestbuy.com/site/pioneer-ts-a-series-6-1-2-3-way-car-speakers-with-multilayer-mica-matrix-cones-pair-black/5557100.p?skuId=5557100
https://www.bestbuy.com/site/metra-speaker-adapter-plates-for-most-2005-and-later-gm-vehicles-2-pack-black/5174025.p?skuId=5174025
https://www.bestbuy.com/site/metra-g-m-speaker-harness-new-multicolored/1739097.p?skuId=1739097
 

·
Registered
Joined
·
48 Posts
I recently encountered the same issue on our 2011. Replaced all 4 speakers and problem was solved.
Went with Rockford 3 ways purchased from Amazon. I opted for the poor man install and sacrificed the oem speaker to mount the new ones on the factory bracket. Spliced the terminals on and all was good. Took about an hour to do all 4.
 

·
Registered
Joined
·
2 Posts
Please someone come up with a solution. My 2011 Traverse only works right side speakers,this morning at 13 degrees the right speakers were very raspy,I popped off the radio trim and shook the wires behind the radio,and the harness,into the drivers door,nothing,,,too cold to go any farther.
 

·
Registered
Joined
·
2 Posts
no sound from left speakers

I removed all the door plugs and had water in right front,and left rear. shook out the water,drove about 20 miles with heater on. front left speaker now works,left rear doesn't. don't make sense unless the rear which had water shorted out the whole left side. Hmmm. left rear speaker will get an ohm check,probably bad ,since it had water. thanks Traverse forum for the trouble shooting tips.
 

·
Registered
Joined
·
47 Posts
Get some dielectric grease and grease up the connectors. Can't imagine having the heater on would do much for drying them out, especially the rears.
I found water in my rear connectors, so much so that the rear wiper stopped working and I was getting a Service Airbag warning. I dried them both out with a blow dryer and then applied dielectric grease to the "female" end. I reassembled it, made sure everything was working, then sealed it up with Gorilla tape to keep water from coming back in.
 

·
Registered
Joined
·
2 Posts
Same problem here - rear speakers completely out at this point, found water in both door connectors. Right front speaker out most of the time, no water in that connector. Left front speaker now goes out when it rains and just about every morning (dew?). Never lose A post speakers.
Here's what I've done to find out what's going on - cut wire to speaker inside car and ran a new wire through door connector without cutting wire (bypassed connector). No change. So I traced wiring.
Seems that the BCM is cutting out all sound. The BCM is basically muxing audio together so you can hear turn signals, bluetooth calls, etc through the car speakers.
So next I bypassed the BCM. I cut speaker wire to the front left speaker and ran a new wire from the back of the radio right to the speaker. NO CHANGE.
I'm thinking water causes a short in the BCM output so the BCM shuts down all audio output - a safety measure. Does this make sense to anyone else?
If this is right, all shorts would need to found and fixed - sounds like a PITA job but I need to find the real fix for this.
I think the posts on here of people replacing a speaker, the radio, or a wire are all related, they got lucky and replaced what was causing their short. For me, since I have water in the connectors, I'm thinking of installing water tight jumper wires in place of the door connectors.
 

·
Registered
Joined
·
13 Posts
Our 2009 Traverse has the same speaker issues when it's humid out.
Sometimes the chime for the turn signal is absent.

Can anyone post pics or point to where I can see how to check the wiring harness/speaker connectors at the doors?

Thanks in advance.
 

·
Registered
Joined
·
2,548 Posts

·
Registered
Joined
·
13 Posts
Some of the speakers aren't coming on even after drying out anymore. A few pins at one of the plugin modules are now deteriorated.

The locks on the door don't always seem to respond to the remote unlock button on depress the first, sometimes the second time.
I can't think of anything else to do but drill some holes at the bottom, maybe, to prevent any more damage.
I don't have a door key, one didn't come with the car when I bought it used. If the electronics stop working I won't be able to get in, I don't think.

Any ideas?
 

·
Registered
Joined
·
2 Posts
I have the same problem in my wife's 2012 Acadia. Only the right rear speaker works sometimes, plus the 2 small tweeters on the A pillars. I filed a compliant because you can't heard the warning sound from the backup sensor. Someone could get hurt or killed especially when this first occurs and the driver is not aware of the problem yet. If everyone files maybe they will finally issue a recall.
 
41 - 58 of 58 Posts
Top