Traverse Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-10 of 10 Results
  1. Audio/Video/Nav
    Hi all, so my car has an issue where the speakers needed to be replaced based on the sound sounding very low in a way and faded and the rear didn't have no sound coming out. I went and took the car to get checked out and the mechanic said the speakers were blown out and he replaced them. After...
  2. General Discussion
    Hey guys, I just had my motor replaced in my 2012 LTZ AWD (141k miles 🙄). I got it back from the shop and now there's a popping noise on the passenger side from the motor compartment. I'm thinking it might be a motor mount, but I replaced those when we had the motor out. I don't believe it's...
  3. Tech Section
    So this one has become more frequent in the last few months. Random intervals, no exact speed, or condition I’ve been able to replicate. Nothing in codes even for inactive. I’m grasping as straws here. There will be times when accelerating you feels some weird pulse/vibration in the pedal. Not...
  4. Engine/Drivetrain
    Year 2013 Model Traverse Variant AWD LTZ Mileage 176,000 I have had this problem for several months and still have not found a solution. I have a problem with the Catalytic Converter that need to be replaced (I replaced the sensors already but now just getting the tube errors) Automatic...
  5. 2018+ Chevy Traverse General Discussion
    Does anyone have an opinion or anything to add that might help me? My exact error message reads: "Traction Control Off, Service Brake System" message. I did see some earlier posts on this subject, but I figured I would post it again and see if there is any new insight on this problem? From...
  6. Engine/Drivetrain
    It's been slow to start for a little while now but still would start without problem. Drove it out one day, came home and it wouldn't turn over. Read codes. Had almost all the spark plug codes and the dreaded p0016-17-8-9 timing codes. Replaced bank 1 sensor a & b camshaft sensors, all the spark...
  7. General Discussion
    I have a 2019 Chevy Traverse where the front right and rear left turn signals do not work. Both stopped working around the same time (after an oil change, not sure if that matters). I changed the front right bulb and that did not solve the problem. I read could be a bad relay but on the fuse...
  8. Engine/Drivetrain
    Hello all, I'm really hoping I find some answers here as I do not know where else to turn to. My girlfriend has a 2014 Traverse LS with about 184K miles. Within this past year we've had around 3 occasions where her car won't start and right now where at a loss as to what is causing it. The...
  9. General Discussion
    Today my mechanic tested the a/c on my 2011 Traverse because the a/c switch blinked a few times and went off, hence no a/c. He found that my rear a/c lines are leaking. Next week I am going to have him use a kit to seal off the rear lines. It is way cheaper than paying over $1,000 to replace...
  10. Interior/Electrical
    I have a 2012 Traverse with a strange issue regarding the door locks. Symptoms: The driver door and tailgate will lock/unlock with key fob, driver door power lock switch or putting the car in Park. All other doors will lock with key fob, driver door power lock switch, or putting the car in...
1-10 of 10 Results
Top