Window switch/motor problem - Chevy Traverse Forum: Chevrolet Traverse Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 03-10-2019, 06:10 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 3
Window switch/motor problem

I have a 2012 traverse LS and recently began having an issue where the rear drivers side window will not go up from the drivers console. The window will go down from there but not up, all other windows work as they should. The rear window switch operates normal up and down. I tried replacing the drivers side panel with a new switch and have the same issue. I also swapped the rear drivers switch with the rear passenger switch and all work as they should. I am now at a loss as I figured it would have been the drivers switch. Someone please help!!!!!
a3ptwin is offline  
post #2 of 4 (permalink) Old 03-10-2019, 08:26 PM
Senior Member
 
Join Date: Apr 2012
Posts: 2,313
Check the door connector for water. Get some dielectric grease and grease it up with that after it's dried out.

2011 2LT FWD replaced by 2017 2LT AWD
greentraverse is offline  
post #3 of 4 (permalink) Old 08-09-2019, 12:13 PM
Junior Member
 
Join Date: Dec 2018
Posts: 4
this happens for the passenger side for me. Doesnt want to work from the driver side switch. i uually take it apart and clean off the connectors and contacts.
lesterb28 is offline  
post #4 of 4 (permalink) Old 08-09-2019, 03:16 PM
Senior Member
 
Join Date: Apr 2012
Posts: 2,313
Quote:
Originally Posted by a3ptwin View Post
I have a 2012 traverse LS and recently began having an issue where the rear drivers side window will not go up from the drivers console. The window will go down from there but not up, all other windows work as they should. The rear window switch operates normal up and down. I tried replacing the drivers side panel with a new switch and have the same issue. I also swapped the rear drivers switch with the rear passenger switch and all work as they should. I am now at a loss as I figured it would have been the drivers switch. Someone please help!!!!!

Quote:
Originally Posted by lesterb28 View Post
this happens for the passenger side for me. Doesnt want to work from the driver side switch. i uually take it apart and clean off the connectors and contacts.
See post #8 here for how to clean:

https://www.traverseforum.com/6-gene...n-t-go-up.html

2011 2LT FWD replaced by 2017 2LT AWD
greentraverse is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Traverse Forum: Chevrolet Traverse Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome