Help! - Chevy Traverse Forum: Chevrolet Traverse Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old Yesterday, 08:18 PM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 1
Help!

I just bought a used 2013 Traverse LTZ and Emergency flashers don't work or any selection to the left of flashers symbol. Can't find info on if its a blown fuse (if there even is a fuse). Also vents in back don't blow any air?
JKElms is offline  
post #2 of 2 (permalink) Old Today, 05:05 AM
Senior Member
 
Join Date: Mar 2011
Posts: 220
Did you purchase from a dealer or private sale or used car lot? Are you asking us if the rear vents don't blow any air? I know sometimes the Emergency button can get stuck on mine, is it sticking perhaps? Maybe something is gummed up there? The fuse would be the same as directional/marker lights. Do they work?
Are you sure on how to operate the rear HVAC controls? Refer to the manual. There is a separate under hood fuse for the rear unit as well as a control module back there too.
electbc is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Traverse Forum: Chevrolet Traverse Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome