Chevy Traverse Forum: Chevrolet Traverse Forum - View Profile: rbarrios

rbarrios rbarrios is offline

Senior Member

  Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Nsettrini
    03-09-2019 09:10 AM - permalink
    Nsettrini
    I am hoping that maybe you can be of some assistance. I have tried just about everything and I have talked to dealerships and mechanics and no one can figure out what is going on with mine. It is a 2010 Chevy traverse LT 3.6L. Timing chains were rattling so I had the timing chains replaced. While changing the timing changes the mechanic also changed the water pump, hormonic balancer, spark plugs and oil. When he was finished the vehicle ran a lot quieter but there is a rough idol and the engine light keeps coming on. The code is P0017. Cam shaft sensor bank 1 sensor B. I have replaced both the camshaft sensor and the cam shaft actuator solenoid. The light is still coming on. A friend has a mechanic diagnostic scanner and he hooked it up. Everything seems to be working except at an idol the timing retards and ALL the temps read 0 for actual and desired. I'm kind of at the end of the road and don't know what to check next. And suggestions?

  About Me

  • Signature
    2010 FWD LT1-Gold Mist Metallic- seats 8.
    Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.

    2013 Equinox 3.6L - 83,000
    2010 Traverse 3.6L- 148,000
    2003 Trailblazer 4.2L- 181,500

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Yesterday 03:25 PM
  • Join Date: 11-25-2008
  • Referrals: 0

  Friends

Showing Friends 1 to 1 of 1
  • JaviLTZ
    • JaviLTZ is offline

  Mentions

09-18-2018
01:44 PM - iexcel mentioned rbarrios in post 2010 Chevy Traverse - Struts are gone?
Thanks rbarrios. When the tire was ...
01-08-2018
08:07 PM - willvv mentioned rbarrios in post Water leaking on driver side
... In that thread rbarrios mentions that a "sec...
10-23-2017
04:14 PM - briannamscott mentioned rbarrios in post Timing Chain Issues and Extended Warranty
rbarrios Yes! The replacement...

  Quotes

06-11-2019
01:25 PM - Win quoted rbarrios in post Taillights
I remember seeing this image ...
06-06-2019
01:47 PM - dave00 quoted rbarrios in post 100,000 mile struts
...the 2012's FYI - Rbarrios, I heard back fro...
06-04-2019
11:28 AM - dave00 quoted rbarrios in post 100,000 mile struts
Dave- I recently contacte...
11:16 AM - rbarrios quoted cbtheman in post Volt gauge
Yes the dash lights also dim ...
11:11 AM - rbarrios quoted dave00 in post 100,000 mile struts
Rbarrios, This is an old ...
05-31-2019
01:56 PM - JMurfe55 quoted rbarrios in post Trans gets stuck in 2nd gear
It is possible it is the wave...
05-29-2019
05:38 PM - Thomcat quoted rbarrios in post Service brake assist warning
do the 2nd gens have the AUX ...
11:26 AM - vw66bus quoted rbarrios in post 2009 Traverse Running HOT
...azy. -- snip -- rbarrios got it right! Car w...
05-22-2019
08:49 AM - mswebraven quoted rbarrios in post Using a Cargo Tray - Backup Sensors
on mine-- its the park assist...
05-21-2019
05:20 PM - rbarrios quoted mswebraven in post Using a Cargo Tray - Backup Sensors
This seems to be a completely d...
04:15 PM - mswebraven quoted rbarrios in post Using a Cargo Tray - Backup Sensors
yeah on my 2010, when I put a...
05-08-2019
04:27 PM - [email protected] quoted rbarrios in post 2018 Traverse LT - Failed Smog at 500 miles.
General Motors Driving Cycle ...
05-07-2019
12:39 PM - cintocrunch quoted rbarrios in post Cooling
not that im aware of. Yo...
04-29-2019
10:51 AM - rbarrios quoted srwa in post Replaced Rear Evaporator core Vacuum
My 15 Traverse seems to b...
04-26-2019
12:50 PM - rbarrios quoted JMurfe55 in post Trans gets stuck in 2nd gear
Also, should I go further and...
12:49 PM - rbarrios quoted JMurfe55 in post Trans gets stuck in 2nd gear
Thank you rbarrios. From read...
04-19-2019
12:40 PM - mike_s quoted rbarrios in post Door connectors repair/replace?
...ve them. Thanks rbarrios, Is this a DIY kit o...
04-12-2019
01:06 PM - rbarrios quoted tnj0510 in post IT'S The Fuse Box!!!!
We just replaced the fuse/re...
04-08-2019
05:01 PM - rbarrios quoted Njtraverse in post Help needed - 2019 DIY Oil Change!
Heads up: I think I read somewh...
04-05-2019
04:03 PM - NBunner32! quoted rbarrios in post Performance issues, low fuel related? Pump Sensor Codes
Nbunner32, is your vehicle an...
 
For the best viewing experience please update your browser to Google Chrome