2010 Traverse downshifts unexpectedly at highway speed - Chevy Traverse Forum: Chevrolet Traverse Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 03-16-2019, 04:10 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Location: Maple Grove, MN
Posts: 2
2010 Traverse downshifts unexpectedly at highway speed

Our 2010 Chevy Traverse will downshift and rev up to about 7000 RPM unexpectedly while driving down the highway. It happens very intermittently but seemed to occur more often at bitter cold temperatures. Weíre talking about 10 to 15 degrees below zero, which is not uncommon here in Minnesota. Also, the Check Engine light does not come on. Pulling over, stopping and shutting the ignition off and back on usually resets it.
Our mechanic replaced the O2 sensor just to try something while he was repairing other issues.
Donít know what we should start replacing, maybe the MAP, speed sensor, or PCM (which would be quite expensive)
Papa0725 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-16-2019, 09:24 PM
Senior Member
 
Join Date: Mar 2011
Posts: 185
Hmmm usually those cold temps bring out the Reduced Engine Power, stabilitrack, and Traction control messages. Pulling over shutting down usually defrosts the Throttle Body. Do you have any moisture in the air intake snorkel?
electbc is offline  
post #3 of 3 (permalink) Old 03-17-2019, 03:16 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Location: Maple Grove, MN
Posts: 2
Thank you for your response electbc. The problem also occurs in relatively warm temps, for Minnesota that is. I have not checked for moisture in the air intake, but Iím pretty sure my mechanic would have noticed if there was. We were getting the Reduced Engine Power, stabilitrack, and Traction control messages. Replacing the timing belt and gears corrected that issue.
I will be taking it back to my mechanic as soon as my daughter-in-law is willing to give it up.
Papa0725 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Traverse Forum: Chevrolet Traverse Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome