TraverseForum.com
Bookmark and Share
July 22, 2014, 09:37:58 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Forum Tip: Click the little orange 'new' icon next to any topic to jump right to the first unread message.
   
   Home   Help Search Gallery Login Register  
Registered users see fewer ads.
Pages: [1] 2  All   Go Down
  Print  
This topic has not yet been rated!
You have not rated this topic. Select a rating:
Author Topic: Heater control ////hot or cold?????  (Read 2997 times)
0 Members and 1 Guest are viewing this topic.
seamus2154
Jr. Member
**
Offline Offline

Posts: 10


View Profile
« on: February 20, 2013, 06:28:26 PM »

Hey Guys, I have a 2009 Traverse LTZ. Just discovered that the heater control seems to be hot or cold. If I have set to 60 it's gets ice cold, if i want 68 lets say it goes to very hot although it's showing 68. Doesn't seem to be adjustable in-between 60-90?Huh? Any ideas to avoid going to the dealer??? Thanks
Logged
rbarrios
Traverse GOD!
********
Offline Offline

Posts: 6884


View Profile
« Reply #1 on: February 20, 2013, 06:52:36 PM »

sounds like one of the cabin sensors is not reading the correct temp for its area.

Does the outside temp read correctly?
Logged

2010 FWD LT1-Gold Mist Metallic- seats 8.
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L -    23,000
2010 Traverse 3.6L-    80,000
2003 Trailblazer 4.2L-173,000
seamus2154
Jr. Member
**
Offline Offline

Posts: 10


View Profile
« Reply #2 on: February 23, 2013, 02:40:20 PM »

Yes outside temp is correct and changes accordingly. The inside is either 60 or 90 no matter how you adjust it in-between the two. If on 60 it is cold and 60. But go to 61 0r 70 and it is coming out at 90.
Logged
ls973800
Hero Member
*****
Offline Offline

Posts: 622


View Profile
« Reply #3 on: February 23, 2013, 04:57:32 PM »

I would also look at the blend door to see if it is binding or sticking or an actuator not responding correctly.  At 60 it is all the way closed and allowing only the A/C cold air to enter.  If you set it to 68 it may open all the way and allow only the heat to enter with no cooling air added. 

May also consider the head unit being defective, although I haven't read about too many problems with them.   More posts about the blend door and actuators.  Any difference in heat/cooling on the driver's side versus the passenger side?  I am guessing you have the auto temp controls with separate settings for each side?

If there is a difference between the two sides that would more than likely suggest an actuator.  There are two on each side for a total of four.

If each side is the same hot/cold, I would look closer at the head unit or the blend door.
Logged

2010 Summit White Traverse LTZ, Nav, Sunroof, Rear Entertainment, Towing, Rear Buckets w/Console-Added $3.00 Nav By-Pass, Rearview Mirror W/Compass, Cabin Air Filter, Lights to Homelink Buttons  SOLD 4/2012
seamus2154
Jr. Member
**
Offline Offline

Posts: 10


View Profile
« Reply #4 on: February 23, 2013, 10:29:52 PM »

I actually didn't  check the pass side independently I will tomorrow.  But yes it is just hot or cold regardless of the mid adjustment. Thanks for the relies so far guys! I'll check back after I check pass side.
Logged
CGIM5804
Full Member
***
Offline Offline

Posts: 215


View Profile
« Reply #5 on: October 27, 2013, 09:50:49 PM »

What is the part number for the hot/cold blend door actuator.  2010 with manual AC
Logged
Kahra
Newbie
*
Offline Offline

Gender: Male
Posts: 5



View Profile
« Reply #6 on: October 28, 2013, 05:09:43 AM »

There are some IC chips behind this meter who controls temp and forward instructions and i think there is some problem with that IC chips so if you can repair itself then check you IC's otherwise you need to go to the dealer.
Logged

Chevrolet Customer Svc
Traverse Freak
******
Offline Offline

Posts: 1321



View Profile WWW
« Reply #7 on: October 28, 2013, 08:41:47 AM »

Hello!

I would be happy to check with my internal resources regarding your question.  I will be in contact with you soon.

Jessica
Chevrolet Customer Care

What is the part number for the hot/cold blend door actuator.  2010 with manual AC

Logged
Chevrolet Customer Svc
Traverse Freak
******
Offline Offline

Posts: 1321



View Profile WWW
« Reply #8 on: October 28, 2013, 10:08:00 AM »

Hi again CGIM5804,

My internal resources want to verify that it is the front air actuator that you are seeking the part number for.  Thanks!

Jessica
Chevrolet Customer Care
Logged
rbarrios
Traverse GOD!
********
Offline Offline

Posts: 6884


View Profile
« Reply #9 on: October 28, 2013, 10:28:01 AM »

What is the part number for the hot/cold blend door actuator.  2010 with manual AC




from my HOW TO- thread


Got the replacement part.
Took me 25 min (with my 3 yr old getting in the way- 'helping me').
Problem resolved. Nice and quiet again. $38.xx for the part.
New part on the left.
Says made in India

Part number on the tag on the bag.
Unless the parts been updated.....



Logged

2010 FWD LT1-Gold Mist Metallic- seats 8.
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L -    23,000
2010 Traverse 3.6L-    80,000
2003 Trailblazer 4.2L-173,000
CGIM5804
Full Member
***
Offline Offline

Posts: 215


View Profile
« Reply #10 on: October 28, 2013, 10:30:28 AM »

Hi again CGIM5804,

My internal resources want to verify that it is the front air actuator that you are seeking the part number for.  Thanks!

Jessica
Chevrolet Customer Care

Hi Jessica,

Yes, it's the hot/cold actuator for the front.
Logged
CGIM5804
Full Member
***
Offline Offline

Posts: 215


View Profile
« Reply #11 on: October 28, 2013, 10:32:37 AM »

Thanks rbarrios!
Logged
Chevrolet Customer Svc
Traverse Freak
******
Offline Offline

Posts: 1321



View Profile WWW
« Reply #12 on: October 28, 2013, 03:09:37 PM »

Thank you!  I'm still waiting to hear back from them, but I will post back to you as soon as I hear anything.  Looks like someone beat me to the punch, but I figured I would just verify the number for you. Smiley

Jessica
Chevrolet Customer Care

Hi Jessica,

Yes, it's the hot/cold actuator for the front.
Logged
CGIM5804
Full Member
***
Offline Offline

Posts: 215


View Profile
« Reply #13 on: October 28, 2013, 09:01:03 PM »

Thanks Jessica, appreciate the follow-up.
Logged
Chevrolet Customer Svc
Traverse Freak
******
Offline Offline

Posts: 1321



View Profile WWW
« Reply #14 on: October 29, 2013, 01:59:34 PM »

Hello again!

I'm sorry for the delay.  The part number that was provided to me is the same number that rbarrios posted earlier: Temp Valve Actuator P/N 20826182.  Please let me know if you have any other questions!

Jessica
Chevrolet Customer Care

Thanks Jessica, appreciate the follow-up.

Logged
CGIM5804
Full Member
***
Offline Offline

Posts: 215


View Profile
« Reply #15 on: October 29, 2013, 09:16:12 PM »

Thank you.
Logged
kbfisher
Newbie
*
Offline Offline

Gender: Male
Posts: 8


View Profile
« Reply #16 on: October 30, 2013, 08:12:07 AM »

We have a 2010 LT. With the system completely off it is putting out very hot air from the vents above the radio. Also, it doesn't switch to defrost or floor. The fan speeds work ok but changing temp does nothing.
Logged
rbarrios
Traverse GOD!
********
Offline Offline

Posts: 6884


View Profile
« Reply #17 on: October 30, 2013, 11:05:46 AM »

kbfisher....
sounds like your actuator- failed in the heat position/
so the blend door is now in the always hot position
You will have to remove the actuator and replace with a new one.

if youre handy--- this wil cost you about $30-$35 for the part on ebay or amazon.
Logged

2010 FWD LT1-Gold Mist Metallic- seats 8.
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L -    23,000
2010 Traverse 3.6L-    80,000
2003 Trailblazer 4.2L-173,000
Chevrolet Customer Svc
Traverse Freak
******
Offline Offline

Posts: 1321



View Profile WWW
« Reply #18 on: October 30, 2013, 12:26:05 PM »

You're welcome!

Jessica
Chevrolet Customer Care

Thank you.

Logged
Chevrolet Customer Svc
Traverse Freak
******
Offline Offline

Posts: 1321



View Profile WWW
« Reply #19 on: October 30, 2013, 02:56:21 PM »

If you need assistance in scheduling a dealership appointment, kbfisher, please let us know!  We would be happy to do so.

Jessica
Chevrolet Customer Care

We have a 2010 LT. With the system completely off it is putting out very hot air from the vents above the radio. Also, it doesn't switch to defrost or floor. The fan speeds work ok but changing temp does nothing.
Logged
Pages: [1] 2  All   Go Up   [ Home | Unread Posts | Unread Replies ]
  Print  
 
Jump to:  
Custom Auto Accessories

Powered by MySQL Powered by PHP Powered by SMF 1.1.14 | SMF © 2006-2011, Simple Machines LLC | Sitemap
©2014 traverseforum.com All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
Valid XHTML 1.0! Valid CSS!