Have you had an air conditioning problem? - Chevy Traverse Forum: Chevrolet Traverse Forum
View Poll Results: Simple YES or NO - Have you had any issues with your air conditioning system (loss of cooling)?
YES 51 69.86%
NO 22 30.14%
I don't know 0 0%
Voters: 73. You may not vote on this poll

Reply
 
LinkBack Thread Tools
post #1 of 36 (permalink) Old 07-13-2015, 09:08 PM Thread Starter
Super Moderator
 
quantum's Avatar
 
Join Date: Dec 2009
Posts: 2,023
Have you had an air conditioning problem?

Don't count damper/fan issues, I'm only interested in loss of freon/broken air conditioner parts.

2010 Traverse 1LT<br />Built 3/10 in Lansing, MI<br /><br />Ontario, Canada
quantum is offline  
Sponsored Links
Advertisement
 
post #2 of 36 (permalink) Old 07-14-2015, 07:39 PM
Junior Member
 
Join Date: Dec 2014
Posts: 1
Re: Have you had an air conditioning problem?

I had problems with my ac light blinking and not blowing cold air. I had it recharged and tested with dye and no leaks found for almost $200. Less than two weeks later, the problems starts again. The dealer had my car for three days before I had to call for an update. They said I had leaks in both lines and esitmated repair cost $937. Is this reasonable? My 2010 Traverse has less than 40,000 miles. There really needs to be a recall out for this and dealers need to stop claiming to perform a 27 point inspection. My car has only been serviced at the dealer and a power steering issue was undetected, leaking transmission, heating blowers malfunction. I am beginning to wonder was the Traverse built to last only five years?



cwalden2 is offline  
post #3 of 36 (permalink) Old 07-15-2015, 02:04 PM
Senior Member
 
Join Date: Jan 2010
Posts: 316
Re: Have you had an air conditioning problem?

I just got home from a local shop that I trust. We had our 2010 in for a loss of cold air. Turns out it was a/the discharge hose. $426 and I was on my way.

2010 Silver Ice Metallic 1LT Traverse AWD w/ tow package 8 seater<br />2008 YELLOW Chevy Aveo5 LS 5 speed<br />1999 Red Mustang GT 5 speed Limited Edition appearance package
odypilots is offline  
Sponsored Links
Advertisement
 
post #4 of 36 (permalink) Old 07-15-2015, 03:15 PM
Senior Member
 
Join Date: Dec 2011
Posts: 199
Re: Have you had an air conditioning problem?

Had ours in a couple of years ago for no AC at 20K. Turned out to be a faulty condenser as it had a leak and replaced/recharged under warranty. So far no more issues and over 54K on the clock now.

2012 Traverse - LTZ (White)<br />2004 BMW 330I (ZHP)<br />1995 Pontiac Firebird T/A (383 Stroker and lots of goodies)
dave00 is offline  
post #5 of 36 (permalink) Old 07-16-2015, 01:07 AM
Member
 
Join Date: Sep 2010
Posts: 32
Send a message via AIM to MrSmilez
Have you had an air conditioning problem?

Ripped my dash apart about a month ago to swap out the evaporator. Had a leak you could smell in the cab. Now I need to do the same to the rear evaporator since the rear isn't blowing cold.


Sent from AutoGuide.com Free App[/color]

Mr. Smilez<br />2009 Chevy Traverse (Family ride)<br />2008 Chevy Impala (Hers)<br />2001 S10 (Work truck)<br />1959 Chevy Impala (Cruiser) *SOLD*<br />1953 Chevy Bel Air (Cruiser) * Will sell for the right price *
MrSmilez is offline  
post #6 of 36 (permalink) Old 08-17-2015, 07:47 AM
Junior Member
 
Join Date: Jan 2014
Posts: 11
Re: Have you had an air conditioning problem?

GM are not doing a recall and are not making changes to prevent these problems so will look at other manufactures next time
bauj is offline  
post #7 of 36 (permalink) Old 08-17-2015, 10:50 AM
Junior Member
 
Join Date: Aug 2015
Posts: 5
Re: Have you had an air conditioning problem?

Quote:
Originally Posted by bauj
GM are not doing a recall and are not making changes to prevent these problems so will look at other manufactures next time
This is absolutely correct. GM has engineered failure into these systems to increase revenue at the dealer level for service and at the corporate level for parts. I have purchased my last GM product.

and yes I've had an AC problem. 2013 traverse has been setting in the driveway for 2 weeks with no AC, cause the only local dealer cant get to it. and the dealer 40 miles away was backed up. it finally goes in tomorrow. with only 30000 miles on the clock. I'm hoping to talk my wife in to trading it for another brand as soon as it has working AC as thats an automatic $2000 deduction in this area.
superspirit is offline  
post #8 of 36 (permalink) Old 08-17-2015, 11:22 AM
Senior Member
 
Join Date: Nov 2008
Posts: 9,533
Re: Have you had an air conditioning problem?

No AC leaks in my 2010...
few days from hitting 100,000.

2010 FWD LT1-Gold Mist Metallic- seats 8.
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L - 60,000
2010 Traverse 3.6L- 128,000
2003 Trailblazer 4.2L- 180,000
rbarrios is offline  
post #9 of 36 (permalink) Old 08-17-2015, 11:55 AM
Junior Member
 
Join Date: Jan 2014
Posts: 11
Re: Have you had an air conditioning problem?

Quote:
Originally Posted by rbarrios
No AC leaks in my 2010...
few days from hitting 100,000.
I' m very happy for you. Wish I could be so lucky.
Do you live in an area that sees the roads salted in winter?
bauj is offline  
post #10 of 36 (permalink) Old 08-17-2015, 12:40 PM
Senior Member
 
Join Date: Nov 2008
Posts: 9,533
Re: Have you had an air conditioning problem?

Im in Southern California.

2010 FWD LT1-Gold Mist Metallic- seats 8.
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L - 60,000
2010 Traverse 3.6L- 128,000
2003 Trailblazer 4.2L- 180,000
rbarrios is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Traverse Forum: Chevrolet Traverse Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome