2013 Freak electrical problem - Chevy Traverse Forum: Chevrolet Traverse Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 06-15-2017, 01:05 AM Thread Starter
Senior Member
 
Join Date: Mar 2013
Posts: 433
Unhappy 2013 Freak electrical problem

2013 LS fwd 50k
Tonight I went to leave work and the radio screen would not change to back up cam. I could not turn off the radio (radio was on with low volume) and no radio functions worked. Also steering wheel volume controls inop. I turned the vehicle off at home and waited a few minutes to restart with same results. I went back an hour later and now everything works fine.
Any ideas or similar problems out there?
I'm scared because I just planned an OK to AZ trip in August.

2013 Traverse LS FWD Silver Ice Metallic<br />GM assist steps, Chrome fuel door, 3.6 DI Caddy badge. Weather Tech floor liners, cargo liner, bug deflector. Covercraft sun shield. Front windows tinted. K&N air filter and cabin filter. Curt hitch and hitch mount 2 bike rack.
velocity5 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-15-2017, 03:57 PM
Junior Member
 
Join Date: Jun 2017
Posts: 1
I have had a similar issue when the vehicle is connecting to a Bluetooth device, like a phone, and that device receives a call or text before fully connected, causing the radio unit to crash. Turning off the car for a few minutes has always resolved the issue. I have had luck ejecting and reinserting a CD getting it to reboot the unit without restarting the car about 75% of the time.
Phillip is offline  
post #3 of 3 (permalink) Old Yesterday, 02:55 AM Thread Starter
Senior Member
 
Join Date: Mar 2013
Posts: 433
No problems since. It must have needed to reboot.

2013 Traverse LS FWD Silver Ice Metallic<br />GM assist steps, Chrome fuel door, 3.6 DI Caddy badge. Weather Tech floor liners, cargo liner, bug deflector. Covercraft sun shield. Front windows tinted. K&N air filter and cabin filter. Curt hitch and hitch mount 2 bike rack.
velocity5 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Traverse Forum: Chevrolet Traverse Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome