2009 Traverse electrical issues - Chevy Traverse Forum: Chevrolet Traverse Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-19-2017, 01:58 AM Thread Starter
Junior Member
 
Join Date: May 2017
Posts: 1
2009 Traverse electrical issues

Hi all! I've got a 09 Traverse with around 130k miles. I'm the second owner. It's had the airbag warning light from under the seat that one place said was a loose connection, and another shop told me it was a recall issue and to take it to the dealer, which is on my to-do list. A few weeks ago, the Traverse started misfiring, then the next day it wouldn't start. I had it towed to the shop, and it had the oil in the air intake. They cleaned that off, changed the plugs and coils, and everything was fine. Now this morning, it wouldn't start up again. The electronics would kick in for a split second then cut out, and I couldn't get the key out or the back hatch open (found that out AFTER loading my 3 dogs in the back, so that was fun!) My husband pulled and reinserted the fuses to troubleshoot and it worked long enough to get the key out. We got a replacement fuse and while it didn't immediately work, once he banged the fuse box lid back in place, the electronics started working and the car was able to start up.

My question is, does that sound like it fixed the problem, or is there a known underlying cause? I know intermittent issues are tough to diagnose, but any help would be appreciated!
Tasha is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-19-2017, 12:45 PM
Senior Member
 
Join Date: Nov 2008
Posts: 9,533
there are issues with the fuse box- especially the one inside getting some water on it.

as for the tail gate-
there is a button at the bottom that you can access from the inside-- (which may be hard with 3 dogs)--- since theyre going to want to know why youre laying back there........
but remove the cap- and insert a screwdriver-- and the tailgate pops open.


click on video to see me popping open the tailgate.

http://vid1156.photobucket.com/album...psfey0rnfz.mp4

2010 FWD LT1-Gold Mist Metallic- seats 8.
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L - 60,000
2010 Traverse 3.6L- 128,000
2003 Trailblazer 4.2L- 180,000
rbarrios is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Traverse Forum: Chevrolet Traverse Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome